Bug 823396 - icedtea-web eats up all cpu with a bank applet
icedtea-web eats up all cpu with a bank applet
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: icedtea-web (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Domurad
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 03:11 EDT by Marko Myllynen
Modified: 2013-01-29 09:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-29 09:49:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2012-05-21 03:11:05 EDT
Description of problem:
Sampo Pankki, part of Danske Bank, is one of the biggest banks in Finland and uses Java for their online service at

https://verkkopankki.sampopankki.fi/

Initially when the applet is being started logs may contain complaints about missing commands like hdparm but once those are available there are two remaining issues of which the other might be an icedtea-web issue.

First, when opening the page and logging in with username/password test/test and selecting the "Always trust" checkbox for all the presented pop-ups one gets an exception which looks like an issue with the applet:


java version "1.7.0_b147-icedtea"
OpenJDK Runtime Environment (fedora-2.1.fc17.6-i386)
OpenJDK Client VM (build 22.0-b10, mixed mode)
eSecurekey (build JL410110) started.
eSecurekey (build JL410110) started.
/builddir/build/BUILD/icedtea-web-1.2/plugin/icedteanp/IcedTeaNPPlugin.cc:684: thread 0xaea02fa0: Error: Unknown plugin value requested.
CallBackFocus not found!
java.lang.ArrayIndexOutOfBoundsException: 3
        at sun.applet.GetMemberPluginCallRequest.parseReturn(GetMemberPluginCallRequest.java:53)
        at sun.applet.PluginStreamHandler.finishCallRequest(PluginStreamHandler.java:300)
        at sun.applet.PluginStreamHandler.handleMessage(PluginStreamHandler.java:224)
        at sun.applet.PluginMessageHandlerWorker.run(PluginMessageHandlerWorker.java:78)
eSecurekey (build JL410110) started.


However, when retrying with clean caches and the trusted certificates removed and never selecting the "Always trust" checkbox when logging in, a pop-up asking for permission is presented after entering username/password but the pop-up window is completely unresponsive and java process eats up all CPU. All what is printed to logs is:


eSecurekey (build JL410110) started.
eSecurekey (build JL410110) started.
/builddir/build/BUILD/icedtea-web-1.2/plugin/icedteanp/IcedTeaNPPlugin.cc:684: thread 0xb0b71f00: Error: Unknown plugin value requested.


OpenJDK/icedtea-web should not hang on any applet like this.

How reproducible:
Always.

Steps to Reproduce:
1. Clear icedtea-web caches and remove any trusted certificates for sampopankki.fi
2. Open https://verkkopankki.sampopankki.fi/ with Firefox
3. Allow everything to run but never select "Always trust" when doing so
4. Login with username/password test/test
5. Notice how a pop-up window presented is completely unresponsive and java process eats up all CPU
Comment 1 Marko Myllynen 2013-01-29 09:49:23 EST
Since the portal is being redone to drop Java usage, this issue is now irrelevant. Thanks.

Note You need to log in before you can comment on or make changes to this bug.