Bug 823417 - perl-Fedora-Bugzilla-0.13-9.fc16 cannot retrieve bug status from Bugzilla 4.2
perl-Fedora-Bugzilla-0.13-9.fc16 cannot retrieve bug status from Bugzilla 4.2
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: perl-Fedora-Bugzilla (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Emmanuel Seyman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 04:33 EDT by Petr Pisar
Modified: 2012-08-26 12:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-26 12:23:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2012-05-21 04:33:32 EDT
Getting status of a bug from Red Hat Bugzilla 4.2 fails. This code:

my $bug = $session->get_bug($bug_id);
if ($bug->full_status !~ 'ASSIGNED') {...}

dies with:

Attribute (bug_status) does not pass the type constraint because: Validation failed for 'Str' with value undef at accessor Fedora::Bugzilla::Bug::bug_status (defined at /usr/share/perl5/vendor_perl/Fedora/Bugzilla/Bug.pm line 309) line 22
        Fedora::Bugzilla::Bug::bug_status('Fedora::Bugzilla::Bug=HASH(0x6138060)') called at /usr/share/perl5/vendor_perl/Fedora/Bugzilla/Bug.pm line 317
        Fedora::Bugzilla::Bug::status('Fedora::Bugzilla::Bug=HASH(0x6138060)') called at /usr/share/perl5/vendor_perl/Fedora/Bugzilla/Bug.pm line 330
        Fedora::Bugzilla::Bug::_build_full_status('Fedora::Bugzilla::Bug=HASH(0x6138060)') called at reader Fedora::Bugzilla::Bug::full_status (defined at /usr/share/perl5/vendor_perl/Fedora/Bugzilla/Bug.pm line 315) line 7
        Fedora::Bugzilla::Bug::full_status('Fedora::Bugzilla::Bug=HASH(0x6138060)') called at /home/petr/redhat/perl/review/scmrequest line 179

This is due to changes in Bugzilla 4.2 API.
Comment 1 Emmanuel Seyman 2012-05-21 13:37:53 EDT
Time to take a serious look at getting the module working.
Comment 2 Emmanuel Seyman 2012-08-26 12:23:47 EDT
This package has been orphaned.

Note You need to log in before you can comment on or make changes to this bug.