Bug 823425 - .ssh/config will not be created or updated automatically when creating domain
.ssh/config will not be created or updated automatically when creating domain
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity high
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 04:50 EDT by Meng Bo
Modified: 2015-05-14 21:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:59:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-05-21 04:50:18 EDT
Description of problem:
'rhc domain create' will not generate .ssh/config file automactically. 

Version-Release number of selected component (if applicable):
rhc-0.93.3

How reproducible:
always

Steps to Reproduce:
1.install rhc client
2.create domain for exist user
3.
  
Actual results:
domain create successful but .ssh/config file has not been created automactically.

Expected results:
.ssh/config should be created after domain created.
or 
remove the 'Checking ~/.ssh/config' from the output if the .ssh/config is useless.

Additional info:

[root@localhost ~]# rhc domain create -n bmengint
Password: ******

OpenShift key found at /root/.ssh/id_rsa.  Reusing...
Checking ~/.ssh/config
Creation successful

You may now create an application.
Comment 1 Xiaoli Tian 2012-05-21 22:20:27 EDT
Since before we generate ~/.ssh/libra_id_rsa in default, and the file listed in ~/.ssh/config also has "IdentityFile ~/.ssh/libra_id_rsa", while we  start to use the new client to alter ssh key or alter domain, it will start to use id_rsa in default, but ~/.ssh/config is still using IdentityFile ~/.ssh/libra_id_rsa,  many old users will have problems here if they do not know what changed  or what happened.
Comment 2 John (J5) Palmieri 2012-05-29 14:05:43 EDT
I just did some tests and since ssh defaults to id_rsa even though we have  IdentityFile ~/.ssh/libra_id_rsa in config if you remove that key from your application and add id_rsa.pub you will still be able to download your app using git.

At most this will confuse the user if they go into the ssh directory and don't understand what the extra files are for.  Removing the entries from config would be worse because some of our older users might be using the libra keys on their servers and removing the config will cause it to stop working since they haven't uploaded their id_rsa.pub key yet.

I suggest QE verifies that keeping these files around causes no harm and we lower the priority so this bug does not block this sprint.  I then suggest we write a migration script early next sprint that checks the keys and servers and automates moving the user to using their default keys if their apps are still using the libra key.  It will also allow the user to opt out and we will not touch the config file at all, at which point we assume the user knows what they are doing.

Once you verify the above please switch this back to modified and add a comment.  I will then lower the priority and serverity.
Comment 3 John (J5) Palmieri 2012-05-29 14:25:12 EDT
I have a fix comming down the line that removes all generation or checking for .ssh/config since it is useless now.
Comment 4 John (J5) Palmieri 2012-05-29 15:37:55 EDT
rhc-0.93.12 will have the fix for the first comment.  It removed checking for and generating a .ssh/config file
Comment 5 Meng Bo 2012-05-31 06:56:40 EDT
checked on rhc-0.93.16, the useless messages are removed.
Comment 6 Xiaoli Tian 2012-05-31 07:08:18 EDT
According to comment 5, it's verified.

Note You need to log in before you can comment on or make changes to this bug.