Bug 823439 - Subscription-manager unsubscribe --all throws 'int' object is unsubscriptable
Subscription-manager unsubscribe --all throws 'int' object is unsubscriptable
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-05-21 05:41 EDT by Shwetha Kallesh
Modified: 2012-05-25 10:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-25 10:21:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2012-05-21 05:41:47 EDT
Description of problem:
Subscription-manager unsubscribe --all throws 'int' object is unsubscriptable 

Version-Release number of selected component (if applicable):

[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-gnome-1.0.2-1.git.2.2b23e6e.el6.x86_64
subscription-manager-migration-1.0.2-1.git.2.2b23e6e.el6.x86_64
subscription-manager-migration-data-1.12.1.8-1.git.0.c91a246.el6.noarch
subscription-manager-firstboot-1.0.2-1.git.2.2b23e6e.el6.x86_64
subscription-manager-1.0.2-1.git.2.2b23e6e.el6.x86_64


How reproducible:


Steps to Reproduce:
1.subscription-manager register --org=admin --user=admin --password=admin
2.subscription-manager subscribe --pool=8ac149343730a547013730a5f10603ac --pool=8ac149343730a547013730a5ed260239
3.subscription-manager unsubscribe --all
  
Actual results:
'int' object is unsubscriptable

Expected results:
Should unsubscribe all from all subscriptions

Additional info:
Comment 3 Devan Goodwin 2012-05-25 10:21:53 EDT
This was caused by running against a development candlepin deploy from within a very specific timeframe where that call returned an int instead of nothing (old) and JSON (new). The client you were using was expecting the new json. Candlepin within this narrow window should not have been deployed.

Closing as per the duplicate bug for 6.3: #823438

Note You need to log in before you can comment on or make changes to this bug.