Bug 823482 - qxl.inf in virtio-win-1.5 is not CRLF line terminator
qxl.inf in virtio-win-1.5 is not CRLF line terminator
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jay Greguske
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 07:12 EDT by Xiaoqing Wei
Modified: 2012-06-20 07:58 EDT (History)
10 users (show)

See Also:
Fixed In Version: virtio-win-1.5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 07:58:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaoqing Wei 2012-05-21 07:12:30 EDT
Description of problem:

qxl.inf in virtio-win-1.5 is not CRLF line terminator
virtio-win is compose for Windows guests, so it's better to keep win style line terminator.

Version-Release number of selected component (if applicable):
virtio-win-1.5.1-1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1.# rpm -ivh virtio-win-1.5.1-1.el6.noarch
2.# find /usr/share/virtio-win/ -name \*.inf -exec file {} \;
3.
  
Actual results:
1) ALL except qxl.inf using UNIX style line terminators

Expected results:
ALL *.inf file should use Windows style line terminators(like 1.4.x)

Additional info:
1.4.x dont have such issue.

# mount -l | grep -i virtio-win
/home/kvm_autotest_root/iso/windows/virtio-win-1.4.0.vfd on /1.4 type vfat (ro,loop=/dev/loop0)
/home/kvm_autotest_root/iso/windows/virtio-win-1.5.1.vfd on /1.5 type vfat (ro,loop=/dev/loop1)

# find /1.4 /1.5 -name qxl.inf -exec file {} \;  
/1.4/i386/Win7/qxl.inf: ASCII English text, with CRLF line terminators
/1.4/i386/WinXP/qxl.inf: ASCII English text, with CRLF line terminators
/1.4/amd64/Win7/qxl.inf: ASCII English text, with CRLF line terminators
/1.5/i386/Win7/qxl.inf: ASCII English text
/1.5/i386/WinXP/qxl.inf: ASCII English text
/1.5/amd64/Win7/qxl.inf: ASCII English text
Comment 1 Xiaoqing Wei 2012-05-21 07:14:58 EDT
This doesn't impact driver installation manually, not high priority issue.

Setting M/M
Comment 4 Jay Greguske 2012-05-22 13:21:02 EDT
Adding Alon and Ronen. This was not intentional; can you guys confirm the QXL repo has CLRF terminators? They may have been lost when I did a git checkout to package them for virtio-win.

Since the installation is still successful, is this really a blocker?
Comment 5 Xiaoqing Wei 2012-05-22 21:49:29 EDT
(In reply to comment #4)

> Since the installation is still successful, is this really a blocker?

Oops, forgot to say that, if someone try to deal with these drivers by automated scripts, may failed due to the line terminator changed, 
such as autotest-kvm( though the autotest now updated and can deal with the non-CLRF line terminators).
Comment 6 Alon Levy 2012-05-23 04:14:01 EDT
(In reply to comment #4)
> Adding Alon and Ronen. This was not intentional; can you guys confirm the
> QXL repo has CLRF terminators? They may have been lost when I did a git
> checkout to package them for virtio-win.

$ file miniport/qxl.inf
miniport/qxl.inf: ASCII text, with CRLF, LF line terminators

yes.

The only real problem is to ensure that no file, including the ascii qxl.inf one, is changed after signature, or the verification will fail, and the driver won't install. We already had it once (qxl-win-<current-version - 1> was bad, qxl-win-<current version> fixed it). But no idea about autotest though, sounds like it should be minor as comment #5 said.
Comment 7 Xiaoqing Wei 2012-05-30 02:04:01 EDT
#mount -ro loop /usr/share/virtio-win/virtio-win-1.5.2.vfd /media/
# find /media/ -name *.inf -exec file {} \;
/media/i386/Win7/qxl.inf: ASCII English text, with CRLF line terminators
/media/i386/WinXP/qxl.inf: ASCII English text, with CRLF line terminators
/media/amd64/Win7/qxl.inf: ASCII English text, with CRLF line terminators

Checked virtio-win-1.5.2, qxl.inf is now CRLF too.
Comment 9 Mike Cao 2012-06-04 03:51:32 EDT
According to comment #7 ,this issue has been fixed ald 
Move status to verified.
Comment 10 errata-xmlrpc 2012-06-20 07:58:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0751.html

Note You need to log in before you can comment on or make changes to this bug.