Bug 82350 - Evolution, imap & sent box
Summary: Evolution, imap & sent box
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: evolution (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords: MoveUpstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-21 15:37 UTC by Nicolas Mailhot
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-23 04:17:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicolas Mailhot 2003-01-21 15:37:34 UTC
I have an email account at www.laposte.net. This is one of the few free imap
services in France, and is run by the local postal service (ie they have an good
public image to maintain and don't try dirty tricks).

Unfortunately their imap server is primarily setup as a webmail backend and has
a very short disconnect time.

I use the imap account as a roaming account and evolution is configured to move
sent mail into an imap folder on the server. What often appens is the following :

1. I launch evolution ; the imap connection is opened and I have acces to my
INBOX and various imap folders

2. by the time I've flushed my spam and found an interesting message I want to
reply to, the imap connection was severed.

3. I try to send my reply. It is moved to the local outbox, sent, then evolution
tries to move it to the imap sendbox and fails. Evolution considers the message
couldn't be send and will send it *again* every time I push send/receive.

4. Either I move it by hand to another folder, or I restart evolution. The imap
connection is live again, evolution can move the message and considers it a
success. The only downside is by this time the message was send in duplicate (or
more).

The problem is evolution considers the message wasn't send even though it only
failed to access an imap folder. It really should try to recover the connection
or move the message to a temporary local folder if this fails, sending (and
failing) all over again just do not cut it.

I'd really like this to work, right now a good archive of send mails that I can
access from everywhere is more important for me than not annoying other people.

Comment 1 Nicolas Mailhot 2003-01-21 15:43:52 UTC
See also ximian bug http://bugzilla.ximian.com/show_bug.cgi?id=37006

Comment 2 Jeremy Katz 2003-01-23 04:17:50 UTC
We won't fix this in a local patch, so it will have to be fixed upstream if
anything.  A workaround is probably to decreate your check interval to something
low enough that the connection doesn't get closed.


Note You need to log in before you can comment on or make changes to this bug.