Bug 823518 - fvwm crashes on clicking on browser back button
fvwm crashes on clicking on browser back button
Status: CLOSED DUPLICATE of bug 823499
Product: Fedora
Classification: Fedora
Component: fvwm (Show other bugs)
16
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 08:52 EDT by nvwarr
Modified: 2012-05-22 01:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-22 01:42:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch which seems to fix the problem (445 bytes, patch)
2012-05-21 08:52 EDT, nvwarr
no flags Details | Diff

  None (edit)
Description nvwarr 2012-05-21 08:52:22 EDT
Created attachment 585805 [details]
Patch which seems to fix the problem

Description of problem:

fvwm sometimes crashes on clicking the "back" button of a browser (e.g. chrome or firefox)

Version-Release number of selected component (if applicable):

fvwm-2.6.5-1.fc16.i686 (from Fedora updates)
fvwm-2.6.4 (built from source)

How reproducible:

Happens from time to time, so not all that reproducible, but if you surf a bit and use the back button a lot, it happens quite often.

Steps to Reproduce:
1. Start surfing (chrome or firefox, but probably other programs too)
2. Use the "back" button on the browser
  
Actual results:
  
Sometimes fvwm crashes.

Expected results:

fvwm should not crash!
  
Additional info:

#0  0x28561c54 in free () from /lib/libc.so.7
#1  0x281b745c in XFreeStringList () from /usr/local/lib/libX11.so.6
#2  0x080ee215 in FlocaleFreeNameProperty (ptext=0x289b3008) at Flocale.c:2358
#3  0x08095e42 in free_window_names (fw=0x289b3000, nukename=0, nukeicon=1) at add_window.c:3171
#4  0x080e664f in EWMH_WMIconName (fw=0x289b3000, ev=0x812d000, style=0x0,  any=0) at ewmh_names.c:175
#5  0x080c8ce5 in EWMH_ProcessPropertyNotify (exc=0x28903180) at ewmh_events.c:1620
#6  0x0807c773 in HandlePropertyNotify (ea=0xbfbfe474) at events.c:3628
#7  0x0807d426 in dispatch_event (e=0xbfbfe498) at events.c:4135
#8  0x0807d52b in HandleEvents () at events.c:4179
#9  0x080a2898 in main (argc=2, argv=0xbfbfe7ac) at fvwm.c:2591

fvwm-2.5.30 (Fedora rpm) does not have this problem, nor does 2.6.3
(built from source). It only appears in 2.6.4 (built from source) and 2.6.5 (Fedora updates). The problem seems to be a change in fvwm/events.c:3386 from:
                if (!WAS_ICON_NAME_PROVIDED(fw))
in 2.6.3 to:
                if (!WAS_ICON_NAME_PROVIDED(fw) || (fw->icon_name.name &&
                        (fw->icon_name.name != fw->name.name)))
in 2.6.4 and 2.6.5. Note that in 2.7.0 it has been reverted back to the 2.6.3 version without the OR, so I guess someone already noticed the problem.

Backing out this change (see attached patch) seems to fix the problem.
Comment 1 nvwarr 2012-05-22 01:42:19 EDT
Sorry, the bug report I submitted didn't show up at first in bugzilla, so I resubmitted and now they both show up.

*** This bug has been marked as a duplicate of bug 823499 ***

Note You need to log in before you can comment on or make changes to this bug.