Bug 82352 - Kernel pretty label is inconsistent in grub.conf
Kernel pretty label is inconsistent in grub.conf
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: mkinitrd (Show other bugs)
2.1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Erik Troan
David Lawrence
:
: 82397 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-21 10:45 EST by Karsten Wade
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-26 11:16:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Wade 2003-01-21 10:45:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
The kernel pretty label (not version number), as generated into /etc/grub.conf,
is inconsisent.  For example:

title Red Hat Linux (2.4.9-e.10debug)
        root (hd0,0)
        kernel /vmlinuz-2.4.9-e.10debug ro root=/dev/hda3
        initrd /initrd-2.4.9-e.10debug.img
title Red Hat Linux (2.4.9-e.10)
        root (hd0,0)
        kernel /vmlinuz-2.4.9-e.10 ro root=/dev/hda3
        initrd /initrd-2.4.9-e.10.img
title Red Hat Linux Advanced Server (2.4.9-e.3)
        root (hd0,0)
        kernel /vmlinuz-2.4.9-e.3 ro root=/dev/hda3
        initrd /initrd-2.4.9-e.3.img

While the kernel version number actually identifies itself as the AS enterprise
version ('e'), the name of the kernel should be consistent as well.  Either "Red
Hat Linux Advanced Server" or "Red Hat Linux".

One example of where this is an issue is in writing documentation discussing
grub; examples must include a messy either/or case.

While it is possible to easily edit /etc/grub.conf to make it consistent, this
should not be a customer's job.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RHLAS 2.1, note kernel pretty label in /etc/grub.conf (for 2.4.9-e.3)
2. Run up2date and update the kernel
3. Note that the kernel pretty label is inconsistent (esp. for 2.4.9-e.10)
    

Actual Results:  Kernel pretty labels are inconsistent.

Expected Results:  Kernel pretty labels should be consistent, either "Red Hat
Linux" or "Red Hat Linux Advanced Server".

Additional info:
Comment 1 Karsten Wade 2003-01-21 16:04:13 EST
*** Bug 82397 has been marked as a duplicate of this bug. ***
Comment 2 Erik Troan 2003-01-26 11:16:08 EST
new mkinitrd gets this from /etc/redhat-release, which should fix this for all
future products

Note You need to log in before you can comment on or make changes to this bug.