Bug 823578 - spice-xpi: don't prepend "s" to usbredir, smartcard and tunnel channels
spice-xpi: don't prepend "s" to usbredir, smartcard and tunnel channels
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-xpi (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: 6.3
Assigned To: Alon Levy
Desktop QE
:
Depends On:
Blocks: 826592
  Show dependency treegraph
 
Reported: 2012-05-21 10:58 EDT by Alon Levy
Modified: 2012-06-20 10:48 EDT (History)
7 users (show)

See Also:
Fixed In Version: spice-xpi-2.7-20.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 10:48:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alon Levy 2012-05-21 10:58:41 EDT
Description of problem:
This is related to #790416

When receiving the list of channels over the spice controller interface from rhev-m/ovirt, we need to handle the prepended 's' by removing it so that spice clients get the name of the channel unmangled.
Comment 2 Alon Levy 2012-05-21 11:12:36 EDT
From 59295182c102eb4e19cba3d4d641eb96f7c4aa75 Mon Sep 17 00:00:00 2001
From: Alon Levy <alevy@redhat.com>
Date: Wed, 9 May 2012 11:49:43 +0300
Subject: [PATCH] SetSSLChannels: add ssmartcard, susbredir, stunnel

Adding some more channels to the RHEL 5 list. The longer winded story is
that ovirt-engine passes us those values because vdsm unconditionally
removes the first letter of every channel name in the secure channels
list (aka SSLChannels here). Instead of changing vdsm, and dealing with
multiple vdsm versions for each cluster, a huge PITA, let spice-xpi
parse some extra channel names.

RHBZ: 823578
---
 SpiceXPI/src/plugin/plugin.cpp |    3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/SpiceXPI/src/plugin/plugin.cpp b/SpiceXPI/src/plugin/plugin.cpp
index 906c985..b7f61ba 100644
--- a/SpiceXPI/src/plugin/plugin.cpp
+++ b/SpiceXPI/src/plugin/plugin.cpp
@@ -337,7 +337,8 @@ void nsPluginInstance::SetSSLChannels(const char *aSSLChannels)
      */
     const char* chan_names[] = {
         "smain", "sdisplay", "sinputs",
-        "scursor", "splayback", "srecord"
+        "scursor", "splayback", "srecord",
+        "susbredir", "ssmartcard", "stunnel"
     };
     const int nnames = sizeof(chan_names) / sizeof(chan_names[0]);
 
-- 
1.7.10.1
Comment 8 errata-xmlrpc 2012-06-20 10:48:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0956.html

Note You need to log in before you can comment on or make changes to this bug.