This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 823596 - REST API not in JON 3.1
REST API not in JON 3.1
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server (Show other bugs)
JON 3.1.0
Unspecified Unspecified
urgent Severity urgent
: ---
: JON 3.1.0
Assigned To: John Sanda
Mike Foley
:
Depends On:
Blocks: jon310-sprint11/rhq44-sprint11
  Show dependency treegraph
 
Reported: 2012-05-21 11:29 EDT by Mike Foley
Modified: 2013-09-11 07:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 07:02:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Foley 2012-05-21 11:29:09 EDT
Description of problem:  REST API not in JON 3.1 


Version-Release number of selected component (if applicable):  JON 3.1 ER4


How reproducible: 100%


Steps to Reproduce:
1.  http://localhost:7080/rest/
2.
3.
  
Actual results:  404


Expected results:    
this is the documented smoke test per heiko email

Additional info:
Comment 1 Mike Foley 2012-05-21 11:35:14 EDT
per BZ triage ... make it installed by default.  also clearly document that it is in Tech Preview (no support )
Comment 4 Heiko W. Rupp 2012-05-21 16:50:24 EDT
This should be enabled out of the box.

basic auth is fully integrated with the RHQ user database.

The REST api is available on ports 7080 / 7443 ; so if the user needs ssl protection, he can go to https://localhost:7443/rest


The examples at http://localhost:7080/rest are examples - so we should not make promises about them

The "real" api is at http://localhost:7080/rest/1/
Comment 6 Charles Crouch 2012-05-22 08:39:59 EDT
Spoke to Heiko about api stability and he expected the vast majority of the current api to be stable going forward.
Comment 7 John Sanda 2012-05-22 11:21:04 EDT
The JON build has been updated so that the REST API is included in the distro. This change will be available in the ER5 build.
Comment 8 John Sanda 2012-06-05 10:40:55 EDT
Moving to ON_QA since this is included in the CR2 build.
Comment 9 Filip Brychta 2012-08-15 08:06:27 EDT
Verified on JON3.1.1.ER2

Note You need to log in before you can comment on or make changes to this bug.