Bug 823624 - mod_cluster enable*/disable*/stop* not working across cluster members.
Summary: mod_cluster enable*/disable*/stop* not working across cluster members.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Plugins   
(Show other bugs)
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent vote
Target Milestone: ---
: ---
Assignee: Simeon Pinder
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: as7-plugin 828893
TreeView+ depends on / blocked
 
Reported: 2012-05-21 17:52 UTC by Simeon Pinder
Modified: 2013-12-07 15:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 828893 (view as bug list)
Environment:
Last Closed: 2013-12-07 15:07:53 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Simeon Pinder 2012-05-21 17:52:04 UTC
Description of problem:
To execute enable*/disable*/start* operations the modcluster plugin requires access to the unique 'jvmRoute' identifier to be able to initiate execution on the appropriate RHQ resources.  Without it there is no way to uniquely identify which 'virtual-hosts' contain which 'contexts' reliably.

Version-Release number of selected component (if applicable):


How reproducible:
N/A

Steps to Reproduce:
1. Create modcluster cluster with two standalone AS7 instances on two different machines.
2. Deploy a web application to the cluster members, attempt to submit stop-context on the nodes. 
3.
  
Actual results:
Stop-Context only affects the contents of one host.

Expected results:
Able to issue Stop-Context commands to any of the node members.

Additional info:

Comment 1 Simeon Pinder 2012-05-21 17:54:52 UTC
This is blocked by issue : https://issues.jboss.org/browse/AS7-4847

Comment 3 Simeon Pinder 2012-06-04 16:46:48 UTC
This is not fixed because of the blocking bug, but the following commits to master and release/jon3.1.x respectively disables the functionality to that it is not available and users are less confused by operations they cannot execute.

master               release/jon3.1.x
633ef4fb             e1d1fe28a51
89bf8dfc             3ad5f3a1668

Comment 4 Charles Crouch 2012-06-05 14:43:48 UTC
These commits have been in JON release builds for a while, pushing to ONQA

Comment 5 Larry O'Leary 2012-11-21 23:00:10 UTC
Removing target as this is not JBoss ON specific. The downstream bug is Bug 828893.

Comment 6 Heiko W. Rupp 2013-12-07 15:07:53 UTC
Is in RHQ for a long time, closing.


Note You need to log in before you can comment on or make changes to this bug.