Bug 823631 - kernel 3.3.5 doesn't boot
kernel 3.3.5 doesn't boot
Status: CLOSED DUPLICATE of bug 754877
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 14:17 EDT by Pierre Ossman
Modified: 2012-05-21 15:51 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 15:51:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2012-05-21 14:17:15 EDT
kernel-3.3.5-2.fc16.x86_64 doesn't work on my machine. Trying to boot from it results in:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

The previous stable kernel, kernel-3.3.4-3.fc16.x86_64, boots and runs just fine.
Comment 1 Pierre Ossman 2012-05-21 14:21:53 EDT
Booting without "quiet" at least allows you to see that it has found the disk, and the partitions on it. The root is an LVM volume though, so I guess it's not setting up LVM properly.

On second thought, shouldn't it be booting into initramfs?
Comment 2 Pierre Ossman 2012-05-21 15:00:18 EDT
And digging further, the initramfs is missing for the latest kernel. It's not on disk, or referenced in grub.cfg.

Reinstalling the kernel package solved the issue. Can't find any errors in the logs when it was improperly installed...
Comment 3 Josh Boyer 2012-05-21 15:30:35 EDT
That'd be a problem in either grubby or dracut.
Comment 4 Brian Lane 2012-05-21 15:51:18 EDT

*** This bug has been marked as a duplicate of bug 754877 ***

Note You need to log in before you can comment on or make changes to this bug.