Bug 823635 - Always Retrieve New SSH key in RHEL AMIs [NEEDINFO]
Always Retrieve New SSH key in RHEL AMIs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ec2-images (Show other bugs)
5.9
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: dgao
mkovacik
: EC2
Depends On: 823634
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 14:31 EDT by Jay Greguske
Modified: 2014-06-02 09:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 823634
Environment:
Last Closed: 2014-06-02 09:01:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jgregusk: needinfo? (jboutaud)


Attachments (Terms of Use)

  None (edit)
Description Jay Greguske 2012-05-21 14:31:04 EDT
+++ This bug was initially created as a clone of Bug #823634 +++

Description of problem:
If an SSH already exists on a RHEL AMI instance, it will not attempt to download another one. This is problematic for rebundles, even though one should be careful to remove their SSH keys anyway. It would be better if a warning was issued instead.

How reproducible:
Always

Steps to Reproduce:
1. Boot an AMI
2. Use ec2-create-image to rebundle it
3. Boot that new AMI with a different key
  
Actual results:
Cannot log in since the new key was not retrieved.

Expected results:
Issue a warning and then download the new key anyway.

Additional info:
The cloud-init package may solve this behavior for us. (see rhbz 770467)
Comment 1 RHEL Product and Program Management 2012-05-21 15:49:52 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 RHEL Product and Program Management 2012-10-30 01:57:21 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2014-03-07 08:33:12 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 4 Jay Greguske 2014-03-07 08:35:49 EST
Adding Jerome to make the call.
Comment 5 RHEL Product and Program Management 2014-06-02 09:01:57 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.