Bug 82367 - KMail not working with some accounts
KMail not working with some accounts
Status: CLOSED UPSTREAM
Product: Red Hat Public Beta
Classification: Retired
Component: kdenetwork (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-21 12:56 EST by Gerry Tool
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-25 09:02:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerry Tool 2003-01-21 12:56:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
I have set up four pop email accounts in Phoebe 2 KMail; two work just fine, and
two return a message that the password is incorrect.  The two that do not work
are on the same server, theclearing.org.

I have checked the setup *many* times to make sure there is not an error.

These same accounts work on every other mail client I use; Evolution, Mozilla
mail on Phoebe 2, Kmail, Mozilla, Evolution on Psyche, Mozilla, Outlook Express
on WinXP.  I have been using them for several years.

I have set up a pop account on that server that you can use for testing.
account name: testcl
server name: theclearing.org
password: testing

You should be able to check mail with other clients and have KMail fail on this
account.  You can either leave messages on there, or take them off when you check.

Version-Release number of selected component (if applicable):
KMail 1.5 (Using KDE 3.1-0.11 Red Hat) from Pheobe 2 install

How reproducible:
Always

Steps to Reproduce:
1.Set up a KMail account using the server theclearing.org
2.Check for mail
3.
    

Actual Results:  An error dialog appears:

Could not login to theclearing.org. The password may be wrong.
The server said: "Password supplied for "testcl@theclearing.org" is incorrect."

Expected Results:  Mail check completes, either retrieving new messages or
closing if there is no new message.

Additional info:
Comment 1 Gerry Tool 2003-02-20 21:02:40 EST
This behaviour is still true in Phoebe 3. 
 
I have also submitted it to kde.org (# 54554) since it also happens in the current beta releases 
of Mandrake 9.1 
Comment 2 Gerry Tool 2003-02-25 09:02:34 EST
I reported this upstream to kde.org and troubleshot the problem with the
developer.  It is not a bug, just abiguity about what the user should enter in
the Login: field.  I entered the total email address rather than just the
username.  Some servers accept this, others do not.

Note You need to log in before you can comment on or make changes to this bug.