Bug 823690 - ZeroDivisionError: float division, File "/usr/lib/anaconda/yuminstall.py", line 221
Summary: ZeroDivisionError: float division, File "/usr/lib/anaconda/yuminstall.py", li...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Brian Lane
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 840685
TreeView+ depends on / blocked
 
Reported: 2012-05-21 21:51 UTC by Rob Smith
Modified: 2013-02-21 09:59 UTC (History)
3 users (show)

Fixed In Version: anaconda-13.21.180-1
Doc Type: Bug Fix
Doc Text:
Cause: repositories without size data cause a divide by zero error. Consequence: Install fails. Fix: Don't divide by 0 Result: Install succeeds.
Clone Of:
Environment:
Last Closed: 2013-02-21 09:59:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
Anaconda trace (279.82 KB, text/plain)
2012-05-21 21:51 UTC, Rob Smith
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0373 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2013-02-20 20:52:28 UTC

Description Rob Smith 2012-05-21 21:51:27 UTC
Created attachment 585895 [details]
Anaconda trace

Description of problem:
Installing with spacewalk generated repodata metadata causes anaconda to fail to install

Version-Release number of selected component (if applicable):
anaconda 13.21.149
spacewalk 1.7

How reproducible:
100%



Steps to Reproduce:
1.build a channel in spacewalk
2.copy repo metadata into distribution image
3.kickstart a machine
  
Actual results:
Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 221, in callback
    self.progress.set_fraction(float(self.doneSize / self.totalSize))
ZeroDivisionError: float division


Expected results:
Kickstart correctly

Additional info:

Comment 2 Brian Lane 2012-05-21 22:14:13 UTC
The primary error here is spacewalk bug 712313, but we really should catch the /0 and just not update the progress bar when we don't have a totalSize.

Comment 3 RHEL Product and Program Management 2012-05-25 06:17:36 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 RHEL Product and Program Management 2012-07-16 22:49:36 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 6 Alexander Todorov 2013-01-17 10:30:09 UTC
The root cause of this issue seems to be primary.xml.gz containing installed="". 


So I'm trying to reproduce: 


1) Create a custom repo
2) Manually edit primary.xml.gz and make sure installed=""
3) createrepo --update .
4) Point anaconda to the repo and install packages from it.


Results:
all packages from my custom repo (which have installed="") were installed and no error was triggered. This was with RHEL 6.3. I can't reproduce.


Rob,
can you try and reproduce outside Satellite?

Comment 7 Jan Stodola 2013-01-18 12:46:01 UTC
Reproduced on RHEL-6.3, primary.xml.gz modified to have installed="" for all packages in the installation repository. I'm going to verify on RHEL-6.4.

Comment 8 Jan Stodola 2013-01-18 13:27:17 UTC
OK, retested using compose RHEL6.4-20130116.3 with anaconda-13.21.194-1.el6.
Installation finished without any traceback, progress bar was not updated during the install, the number of installed packages showed correct number during the install.
Tested both manual graphical and kickstart installation in text mode.

Moving to VERIFIED.

Comment 9 errata-xmlrpc 2013-02-21 09:59:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0373.html


Note You need to log in before you can comment on or make changes to this bug.