Bug 823715 - boinc daemon script not installed like documentation says
boinc daemon script not installed like documentation says
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: boinc-client (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Milos Jakubicek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 20:52 EDT by David M.
Modified: 2012-07-07 18:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-07 18:45:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boinc Fedora instructions (5.19 KB, application/octet-stream)
2012-05-21 20:52 EDT, David M.
no flags Details
ls of my /etc.init.d/ (322 bytes, text/plain)
2012-05-21 20:54 EDT, David M.
no flags Details

  None (edit)
Description David M. 2012-05-21 20:52:40 EDT
Created attachment 585910 [details]
Boinc Fedora instructions

Description of problem:

The boinc clint does not create daemon script in /etc/init.d/boinc-client.

The documentation in /usr/shar/doc/boinc-client-6.12.43/USAGE_FEDORA says:

"
.....
  What the installer does                               
   1. Creates the daemon script at /etc/init.d/boinc-client.
......
"


because the daemon script is not installed in /etc/init.d/

"
.....
/sbin/chkconfig boinc-client on
.....
"

will not set the boinc-client to start automatically when the computer boots.

Version-Release number of selected component (if applicable):

boinc-client-6.12.43

How reproducible:

always

Steps to Reproduce:
1. yum install boinc-client
2. /sbin/chkconfig boinc-client on

  
Actual results:

error reading information on service boinc-client: No such file or directory

Expected results:

Daeon should be set to start every time Fedora boots.


Additional info:

Attached is the USAGE_FEDORA documentation along with the ls of my /etc/init.d
Comment 1 David M. 2012-05-21 20:54:34 EDT
Created attachment 585911 [details]
ls of my /etc.init.d/
Comment 2 Nicolas GIF 2012-06-23 05:12:29 EDT
This is because init.d is not udes anymore but system.d.

Daemon script is there : /usr/lib/systemd/system/boinc-client
But it has a problem anyway. systemd cannot recognize it because its name should be 'boinc-client.service'.

I did the following to fix the service problem:

#cd /usr/lib/systemd/system
#ln -s boinc-client boinc-client.service
Comment 3 Milos Jakubicek 2012-06-23 05:26:51 EDT
This is solved by https://admin.fedoraproject.org/updates/boinc-client-6.12.43-2.r25218svn.fc17
Comment 4 David M. 2012-07-07 18:45:59 EDT
Boinc-client services now seem to work properly.  Documenation now seems consistant with system behavior.

Note You need to log in before you can comment on or make changes to this bug.