Bug 823733 - Fedora 17 installer and X-Windows does not detect Lenovo Synaptic mouse
Fedora 17 installer and X-Windows does not detect Lenovo Synaptic mouse
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 22:48 EDT by Naipaul Ojar
Modified: 2012-05-22 08:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-22 02:54:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naipaul Ojar 2012-05-21 22:48:47 EDT
Description of problem:
Lenovo Synaptic mouse on laptop was detected and was operational when booted from DVD or when system was booted and in X-Windows. This laptop Lenovo w510 was previously installed with F13 and F16 successfully.

With F17, the mouse was not detected at install time, during reboot or during Gnome 3.4 X-Windows.

I installed the xorg-x11-drv-synaptics-1.6.1-1.fc17.x86_64.rpm and the synaptic mouse is still not detected.

Version-Release number of selected component (if applicable):
Fedora 17 Beta

Synaptic mouse has the following parts:-
a. 'moveable nipple'
b. synaptic area to move finger
c. two separate sets of mouse buttons: 1 x 3-button + 1 x 2-button
 None of the three methods are operational
 - I have a disk with F16 & F13 and they both work with this laptop today, eliminating hardware detection.

How reproducible:
a. Restarted installation 2 times
b. Installed synaptics package and logged out/in 2 times
c. Rebooted laptop 2 times

Steps to Reproduce:
1. Insert Fedora 17 Beta DVD and boot from DVD, mouse is not detected
2. Install synaptics package and mouse is still not detected
3. I atached USB mouse and I am now able to manoeuver, but synaptic mouse is still not responding.
  
Actual results:
No errors seen or mouse not detected

Expected results:
Errors in /var/log/Xorg.0.log

Additional info:
Comment 1 Naipaul Ojar 2012-05-22 02:54:39 EDT
My test machine, which I used to test Fedora 13 and Fedora 16, came back from repair for an overheating CPU, actually came back with a broken synaptics mouse.

I tested the machine booting up on F16, but not to actually use it.

After raising the bug report, I swapped in the old F13 disk, this session, and the synaptics mouse is still not working.

I am closing this bug report, as I cannot verify my original claim until I get my mouse resolved.
Comment 2 Panu Matilainen 2012-05-22 06:17:33 EDT
In any case assigning to more appropriate component, "synaptic" is a package management frontend and nothing to do with mouses.
Comment 3 Naipaul Ojar 2012-05-22 08:00:08 EDT
To confirm, hardware issue with laptop post laptop fan replacement.

Hardware issue resolved and I can use the mouse with Fedora 17 :-
a) From CD
b) From Gnome Login

Note You need to log in before you can comment on or make changes to this bug.