Bug 823735 - RFE: add tool to inject new rpms into rhevh
RFE: add tool to inject new rpms into rhevh
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: FutureFeature
Depends On:
Blocks: 816255 823651 839774
  Show dependency treegraph
 
Reported: 2012-05-21 22:55 EDT by Mike Burns
Modified: 2016-04-26 11:09 EDT (History)
10 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-3.el6
Doc Type: Enhancement
Doc Text:
The edit-node command has been augmented to allow for additional packages to be installed. These can be regular packages or driver update packages. The --install-dup option has been renamed to --install-kmod and an additional option --install for standard RPMS has been included.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:31:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2012-05-21 22:55:32 EDT
Description of problem:
We need a tool that can crack open an iso and add an rpm offline.  

No live installation will be supported at this time

Expected Results:

user runs command line tool on a separate host that will install a specified rpm and it's dependencies into a RHEV-H ISO image.  yum repo urls should be passed on the command line
Comment 1 Mike Burns 2012-05-21 23:02:08 EDT
Also, tool will need to support using yum from a non-standard location (or a different command altogether)
Comment 2 RHEL Product and Program Management 2012-07-10 04:22:42 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 21:48:58 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 8 errata-xmlrpc 2013-02-28 11:31:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.