Bug 823738 - RFE: add ability to rebuild initramfs to plugin injection tool
RFE: add ability to rebuild initramfs to plugin injection tool
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
x86_64 Linux
urgent Severity medium
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: FutureFeature
Depends On:
Blocks: 816255 823651 839774
  Show dependency treegraph
 
Reported: 2012-05-21 23:05 EDT by Mike Burns
Modified: 2016-04-26 10:25 EDT (History)
10 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-3.el6
Doc Type: Enhancement
Doc Text:
During the plugin injection process, modules or changes in the boot kernel maybe required for a successful boot. This enhancement will add the ability to regenerate initramfs to the plugin injection tool when changes are being made to the image.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:31:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2012-05-21 23:05:45 EDT
Description of problem:
Add ability to regenerate initramfs to plugin injection tool

Rationale:

During plugin injection process, a change may be made that must go into the boot kernel.  For example a new storage driver might be installed which is required for successful boot.

Feature details:

Injection tool should either take a flag or always rebuild the initramfs when changes are being made to the image
Comment 1 RHEL Product and Program Management 2012-07-10 04:22:25 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 21:49:12 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 3 Joey Boggs 2012-08-06 10:16:44 EDT
http://gerrit.ovirt.org/#/c/6877/
Comment 7 errata-xmlrpc 2013-02-28 11:31:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.