Bug 823745 - RFE: edit-node tool should alter version information
RFE: edit-node tool should alter version information
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: FutureFeature
Depends On:
Blocks: 816255 823651 839774
  Show dependency treegraph
 
Reported: 2012-05-21 23:20 EDT by Mike Burns
Modified: 2016-04-26 10:05 EDT (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-12.el6
Doc Type: Enhancement
Doc Text:
The edit-node command now shows the modifications to the ISO to reflect the included kmod parameters. This creates a different ISO image name for the node whenever a Red Hat Enterprise Virtualization Hypervisor image is modified for easier identification.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:33:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2012-05-21 23:20:44 EDT
Description of problem:
when editing a RHEV-H image, a plugin needs to automatically alter the version information in the node to indicate that it is not just a base image.

This should be supported via a flag to edit-node that contains a string to be appended.

Example:

rhevh-6.3-20120521.0.el6 image

run injection tool with --name=storage_dup

rhevh-6.3-20120521.0.storage_dup.el6


In the case of multiple dups, keep appending to the end:

rhevh-6.3-20120521.0.storage_dup.network_dup.el6

In the case of a missing --name (or similar) option, we should either:

1.  Fail and require
2.  figure out some smart way to automatically determine the name, maybe the name of the base rpm being installed

Some change to the version *Must* be made on *all* plugin injections
Comment 1 RHEL Product and Program Management 2012-07-10 04:22:08 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 21:49:24 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 3 Joey Boggs 2012-07-16 16:00:53 EDT
http://gerrit.ovirt.org/#/c/6202/

/etc/system-release line tagged with
(Edited) edit-node was ran on the iso
(Edited, Unsigned)  edit-node was ran with --nogpgcheck option
Comment 21 errata-xmlrpc 2013-02-28 11:33:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.