Bug 82375 - test for ypbind running after it is launched is wrong
test for ypbind running after it is launched is wrong
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: ypbind (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-21 13:47 EST by Robert Ehrlich
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:34:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
correction for the test for a running ypbind in /etc/init.d/ypbind (1.67 KB, patch)
2003-01-21 14:13 EST, Robert Ehrlich
no flags Details | Diff

  None (edit)
Description Robert Ehrlich 2003-01-21 13:47:20 EST
Description of problem:


Version-Release number of selected component (if applicable):
# Version:      @(#) /etc/init.d/ypbind.init 1.2

How reproducible:

execute:
/etc/init.d/ypbind restart
in such an environement that the daemon ypbind is sufficiently slow that
an immediate ypwhich doesn't succeed.

Steps to Reproduce:
1.
2.
3.
    
Actual results:

The script pretends that the launch of ypbind failed, although it
succeeds when starte by typing just the command ypbind

Expected results:
The script should show that the launch of ypbind succedded.

Additional info:
Comment 1 Robert Ehrlich 2003-01-21 14:13:57 EST
Created attachment 89480 [details]
correction for the test  for a running ypbind in /etc/init.d/ypbind

In the script /etc/init.d/ypbind, in the function "start", there is an "until"
loop which seems intended to test that ypbind runs correctly after it is
started, by executing at most 3 times the command ypwhich. However it will do
so only if the first attempt succeeds, i.e. the lines between the following
"do" and "done" are never executed. This is because the first line betewen
these "do" and "done" is:
RETVAL=$?
and $? is the result of the test of the above "until", which is necessarily
false if we get here. Then the test after loop exit (if [ $RETVAL -eq 0 ];
then)
will always find RETVAL not zero and consider that ypbind don't run correctly
and kill it, even if a later ypwhich succeeded.
Comment 2 Bill Nottingham 2006-08-07 16:10:31 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 3 Bill Nottingham 2006-10-18 13:34:22 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.