Bug 823766 - Bogus provides/requires perl(Automake::...)
Bogus provides/requires perl(Automake::...)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: automake (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Raiskup
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 02:23 EDT by Ralf Corsepius
Modified: 2012-09-27 02:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 10:01:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against automake/master (3.06 KB, patch)
2012-05-22 13:10 EDT, Ralf Corsepius
no flags Details | Diff
Patch used by previous patch (435 bytes, patch)
2012-05-22 13:12 EDT, Ralf Corsepius
no flags Details | Diff

  None (edit)
Description Ralf Corsepius 2012-05-22 02:23:57 EDT
Description of problem:

The automake-rpm in rawhide carries bogus perl(Automake::...) provides/requires:

# rpm -q -provides -p automake-1.11.5-1.fc18.noarch.rpm 
...
perl(Automake::...)
...


# rpm -q --requires -p automake-1.11.5-1.fc18.noarch.rpm 
...
perl(Automake::...)  
...

Version-Release number of selected component (if applicable):
automake-1.11.5-1.fc18.noarch.rpm

Actual results:
The automake package provides/requires perl(Automake::...).

Expected results:
The automake package not to provide/require perl(Automake::...).

Additional info:
* AFAIS from automake.spec, the cause is its perl-module filter not having been updated to recent rpm conventions. The old filter, the spec still contains, now is dysfunctional.

* The F17 package suffers from the same issue.

* The F16 package also would suffer from this issue, if it was rebuilt.
So far, however, F16 ships an F14 built automake, where these perl-module filters had been functional.
Comment 1 Ralf Corsepius 2012-05-22 13:10:20 EDT
Created attachment 586086 [details]
Patch against automake/master

Besides this BZ, this patch addresses several further issues (C.f. %changelog).

Scratch-build against rawhide:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4094868
Comment 2 Ralf Corsepius 2012-05-22 13:12:28 EDT
Created attachment 586087 [details]
Patch used by previous patch

This patch addresses a bug in automake-1.11.5's testsuite's tests/compile_f90_c_cxx.test, which deterministically shows when building automake-1.11.5 for rawhide.
Comment 3 Pavel Raiskup 2012-09-26 10:01:03 EDT
Ralph, thanks for your work! .. all possible changes are (maybe slightly
modified) addressed in rawhide/f18 now.  I changed it little because automake
has been rebased in the meantime.

Relevant build for rawhide:

  http://koji.fedoraproject.org/koji/taskinfo?taskID=4528242

And for F18 (still running):

  http://koji.fedoraproject.org/koji/taskinfo?taskID=4528845

I'm marking this like resolved, feel free to reopen it when something goes
wrong,

Pavel
Comment 4 Fedora Update System 2012-09-27 02:28:27 EDT
automake-1.12.2-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/automake-1.12.2-5.fc18

Note You need to log in before you can comment on or make changes to this bug.