Bug 82377 - mount can't do tmpfs during installer
mount can't do tmpfs during installer
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-21 14:00 EST by Alexandre Oliva
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-28 21:22:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2003-01-21 14:00:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Even though /proc/filesystems says tmpfs is available in the installer kernel,
/usr/bin/mount -> busybox has failed in all my attempts to mount a tmpfs
filesystem.  I tried leaving the device out, putting it in as the directory on
which I wanted to mount, naming /dev/zero, /dev/null, creating entries in
/etc/fstab, specifying the size or leaving it out, all to no avail.  It always
failed with `Invalid argument'.

Version-Release number of selected component (if applicable):
phoebe2

How reproducible:
Always

Steps to Reproduce:
1.Boot the installer and get to stage2
2.mkdir /mnt/newtmp
3.mount -t tmpfs {,-o size=8m} {,/mnt/newtmp,/dev/zero,/dev/null} /mnt/newtmp
    

Actual Results:  mount fails with an error ending with `: Invalid argument'

Expected Results:  at least one of the above should work

Additional info:

using /dev/ram serves as a work around for now (bug 80209)
Comment 1 Daniel Walsh 2003-01-24 12:23:52 EST
I tried this against the latest busybox and it worked fine

sudo ./mount -t tmpfs -o size=8m /mnt/zero /mnt/newtmp

ls -l mount 
lrwxrwxrwx    1 dwalsh   dwalsh         13 Jan 24 12:16 mount -> /sbin/busybox

busybox-0.60.5-2
Comment 2 Alexandre Oliva 2003-01-25 21:22:47 EST
It is true that busybox 0.60.5-5 (as in a full install of phoebe 2) can mount
tmpfs.  The problem occurs in the installer environment, though, with a command
line identical to that which works in the installed system (same as what you
use, except for s,mnt/zero,dev/zero,.  I've verified that /dev/zero exists, so
that's not it.

Perhaps we have an old version of busybox in the installer image?  Or maybe
there's something wrong with the kernel?  Anyway, I'm changing this to anaconda
since the problem doesn't seem to be in busybox, but rather in the installer
environment (even if it's just that the busybox build in the installer has to be
updated).
Comment 3 Jeremy Katz 2003-01-28 00:45:40 EST
I'm pretty sure tmpfs isn't in the BOOT kernel for space reasons.
Comment 4 Alexandre Oliva 2003-01-28 10:44:25 EST
How did you check that tmpfs isn't supported in the BOOT kernel?  cat
/proc/filesystems says it is there so, if it is not supposed to be, we can
probably reduce the kernel some more, or put in whatever little bits are missing
for tmpfs to work correctly, which would help solving bug 80203.
Comment 5 Jeremy Katz 2003-01-28 21:22:22 EST
I looked in the kernel config :)   

from config-i386-BOOT
# CONFIG_TMPFS is not set

Note You need to log in before you can comment on or make changes to this bug.