Bug 823770 - New: Bogus provides/requires perl(Autom4te::...)
New: Bogus provides/requires perl(Autom4te::...)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: autoconf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 02:45 EDT by Ralf Corsepius
Modified: 2012-06-27 23:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 23:28:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against autoconf/master (3.04 KB, patch)
2012-05-22 06:48 EDT, Ralf Corsepius
no flags Details | Diff

  None (edit)
Description Ralf Corsepius 2012-05-22 02:45:56 EDT
Description of problem:

The autoconf-rpm in rawhide carries bogus perl(Autom4te::...)
provides/requires:

# rpm -q -provides -p  autoconf-2.69-1.fc18.noarch.rpm
...
perl(Autom4te::...)
...


# rpm -q --requires -p  autoconf-2.69-1.fc18.noarch.rpm
...
perl(Autom4te::...)  
...

Version-Release number of selected component (if applicable):
autoconf-2.69-1.fc18.noarch.rpm

Actual results:
The autoconf package provides/requires perl(Autom4te::...).

Expected results:
The autoconf package not to provide/require perl(Autom4te::...).

Additional info:
* AFAIS from autoconf.spec, the cause is its perl-module filter not having been
updated to recent rpm conventions. The old filter, the spec still contains, now
is dysfunctional.

* The F17 package suffers from the same issue.

* The F16 package in git would also suffer from this issue, if it was rebuilt.
So far, however, F16 ships an F15-built automake binary, which doesn't expose this bug.
Comment 1 Ralf Corsepius 2012-05-22 05:49:33 EDT
FYI: This issue has caused me to furtherly look into this package and has caused me to find further issues. I am currently working on a patch, which I hope to be able to propose soon.
Comment 2 Ralf Corsepius 2012-05-22 06:48:26 EDT
Created attachment 586000 [details]
Patch against autoconf/master

This is before-mentioned patch.

Besides this BZ, it addresses several further issues (C.f. %changelog).

Scratch-build against rawhide:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4093680

Scratch-build against f17:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4093682
Comment 3 Karsten Hopp 2012-06-18 08:16:24 EDT
fixed in autoconf-2.69-2.fc18 and autoconf-2.68-4.fc17

thanks for your patch !
Comment 4 Fedora Update System 2012-06-18 08:19:01 EDT
autoconf-2.68-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/autoconf-2.68-4.fc17
Comment 5 Fedora Update System 2012-06-19 11:05:33 EDT
Package autoconf-2.68-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing autoconf-2.68-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9596/autoconf-2.68-4.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-06-27 23:28:56 EDT
autoconf-2.68-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.