Bug 823859 - nagios-plugins-check_sip x86_64 broken, reason: typo /usr/lib6464/nagios/plugins
nagios-plugins-check_sip x86_64 broken, reason: typo /usr/lib6464/nagios/plugins
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nagios-plugins-check_sip (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 06:26 EDT by Joachim Jaeckel
Modified: 2012-09-26 05:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 16:39:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Jaeckel 2012-05-22 06:26:02 EDT
Description of problem:
Plugin does not work due to typo in line 29:
  use lib "/usr/lib6464/nagios/plugins";
  (should be /usr/lib64/)


Version-Release number of selected component (if applicable):
  nagios-plugins-check_sip-1.3-1.fc16.x86_64



How reproducible:
  always

Steps to Reproduce:
1. call from shell: /usr/lib64/nagios/plugins/check_sip
2.
3.
  
Actual results:
Can't locate utils.pm in @INC (@INC contains: /usr/lib6464/nagios/plugins /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/lib64/nagios/plugins/check_sip.2012-05-06 line 30.
BEGIN failed--compilation aborted at /usr/lib64/nagios/plugins/check_sip.2012-05-06 line 30.



Expected results:
This plugin tests the sip service on the specified host.

Usage: check_sip -u sip:uri@example.com [-H host -p PORT -f sip:fromuri@example.com -w WARNTIME -s]
...


Additional info:
Comment 1 Fedora Update System 2012-05-22 06:48:16 EDT
nagios-plugins-check_sip-1.3-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/nagios-plugins-check_sip-1.3-2.fc15
Comment 2 Fedora Update System 2012-05-22 06:48:49 EDT
nagios-plugins-check_sip-1.3-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/nagios-plugins-check_sip-1.3-2.fc16
Comment 3 Fedora Update System 2012-05-22 06:49:07 EDT
nagios-plugins-check_sip-1.3-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/nagios-plugins-check_sip-1.3-2.el5
Comment 4 Fedora Update System 2012-05-22 06:49:26 EDT
nagios-plugins-check_sip-1.3-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/nagios-plugins-check_sip-1.3-2.fc17
Comment 5 Fedora Update System 2012-05-22 06:49:38 EDT
nagios-plugins-check_sip-1.3-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/nagios-plugins-check_sip-1.3-2.el6
Comment 6 Fedora Update System 2012-05-22 11:31:05 EDT
Package nagios-plugins-check_sip-1.3-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing nagios-plugins-check_sip-1.3-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-5931/nagios-plugins-check_sip-1.3-2.el6
then log in and leave karma (feedback).
Comment 7 Joachim Jaeckel 2012-05-22 19:20:17 EDT
Update from epel-testing works for me.
Tnx!
Comment 8 Joachim Jaeckel 2012-05-24 18:52:09 EDT
Sorry, update from epel-testing does not work.

1. call from shell: /usr/lib64/nagios/plugins/check_sip works.

2. call via nagios does not work.

Turned on debugging in Nagios: debug_level=4095

Logfile shows:
[1337898821.126134] [016.1] [pid=22231] HOST: myhost, SERVICE: SIP test, CHECK TYP
E: Active, OPTIONS: 0, SCHEDULED: Yes, RESCHEDULE: Yes, EXITED OK: No, RETURN CO
DE: 3, OUTPUT: **ePN failed to compile /usr/lib64/nagios/plugins/check_sip: "Num
ber found where operator expected at (eval 1) line 129, near "case 1"" at /usr/s
bin/p1.pl line 160.\n
Comment 9 Joachim Jaeckel 2012-05-24 19:17:14 EDT
Found unsolved problems of other people using Switch.pm with Nagios ePN.

So i changed the script from line 127:
##switch($resend_times){
##  case 1 { ualarm(500000); }
##  case 2 { $TIMEOUT=1; alarm($TIMEOUT); }
##  case 3 { $TIMEOUT=2; alarm($TIMEOUT); }
##  else { $TIMEOUT=4; alarm($TIMEOUT); }
##}
if($resend_times==1)
  { ualarm(500000); }
elsif($resend_times==2)
  { $TIMEOUT=1; alarm($TIMEOUT); }
elsif ($resend_times==3)
  { $TIMEOUT=2; alarm($TIMEOUT); }
else
  { $TIMEOUT=4; alarm($TIMEOUT); }

Now it works.
Comment 10 Peter Lemenkov 2012-06-27 10:17:59 EDT
(In reply to comment #9)
> Found unsolved problems of other people using Switch.pm with Nagios ePN.
> 
> So i changed the script from line 127:
> ##switch($resend_times){
> ##  case 1 { ualarm(500000); }
> ##  case 2 { $TIMEOUT=1; alarm($TIMEOUT); }
> ##  case 3 { $TIMEOUT=2; alarm($TIMEOUT); }
> ##  else { $TIMEOUT=4; alarm($TIMEOUT); }
> ##}
> if($resend_times==1)
>   { ualarm(500000); }
> elsif($resend_times==2)
>   { $TIMEOUT=1; alarm($TIMEOUT); }
> elsif ($resend_times==3)
>   { $TIMEOUT=2; alarm($TIMEOUT); }
> else
>   { $TIMEOUT=4; alarm($TIMEOUT); }
> 
> Now it works.

Well, can't confirm - I just tried it on my EL5 and it works fine. Did you try it on Fedora only?
Comment 11 Joachim Jaeckel 2012-06-27 13:08:16 EDT
(In reply to comment #10)
> Well, can't confirm - I just tried it on my EL5 and it works fine. Did you
> try it on Fedora only?

Yes, i only tested on Fedora 16.

On el5 you still have the old nagios 2, on fedora you have nagios 3.

Nagios 3 uses ePN. ePN is an embedded Perl interpreter that runs inside Nagios, similar to mod_perl in Apache.

As described in comment 8 the problem shows only when plugin is called from nagios.
Comment 12 Fedora Update System 2012-07-03 15:35:41 EDT
nagios-plugins-check_sip-1.3-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Joachim Jaeckel 2012-07-03 16:47:43 EDT
Problem not solved for Fedora.
Comment 14 Fedora Update System 2012-09-16 02:25:12 EDT
nagios-plugins-check_sip-1.3-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/nagios-plugins-check_sip-1.3-4.fc17
Comment 15 Fedora Update System 2012-09-16 02:25:24 EDT
nagios-plugins-check_sip-1.3-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/nagios-plugins-check_sip-1.3-4.fc16
Comment 16 Fedora Update System 2012-09-16 02:25:35 EDT
nagios-plugins-check_sip-1.3-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nagios-plugins-check_sip-1.3-4.fc18
Comment 17 Fedora Update System 2012-09-16 02:25:46 EDT
nagios-plugins-check_sip-1.3-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/nagios-plugins-check_sip-1.3-4.el6
Comment 18 Fedora Update System 2012-09-16 14:31:05 EDT
Package nagios-plugins-check_sip-1.3-4.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing nagios-plugins-check_sip-1.3-4.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-12931/nagios-plugins-check_sip-1.3-4.el6
then log in and leave karma (feedback).
Comment 19 Fedora Update System 2012-09-20 16:39:50 EDT
nagios-plugins-check_sip-1.3-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2012-09-26 04:48:24 EDT
nagios-plugins-check_sip-1.3-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2012-09-26 05:17:17 EDT
nagios-plugins-check_sip-1.3-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.