Bug 823860 - Broken links on installer/start.jsf page
Broken links on installer/start.jsf page
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Installer (Show other bugs)
JON 3.1.0
Unspecified Unspecified
urgent Severity urgent
: ---
: JON 3.1.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: jon310-sprint11/rhq44-sprint11 825338
  Show dependency treegraph
 
Reported: 2012-05-22 06:28 EDT by Filip Brychta
Modified: 2013-09-11 06:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 825338 (view as bug list)
Environment:
Last Closed: 2013-09-11 06:58:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot (108.54 KB, image/png)
2012-05-22 06:28 EDT, Filip Brychta
no flags Details

  None (edit)
Description Filip Brychta 2012-05-22 06:28:04 EDT
Created attachment 585989 [details]
screenshot

Description of problem:
All links on installer/start.jsf page are broken. See attached picture

Version-Release number of selected component (if applicable):
jon-server-3.1.0.ER4

How reproducible:
Always
Comment 1 Mike Foley 2012-05-23 09:09:19 EDT
marking this urgent.
Comment 2 Deon Ballard 2012-05-23 11:58:58 EDT
For reference, here is an example of one of the broken links:
http://docs.redhat.com/docs/en-US/JBoss_Operations_Network/3.0/html/Configuring_JON_Servers_and_Agents/server-properties.html-DatabaseConnectionURL


There are two issues here. 

1. This is my fault; it's a bit inside baseball, but when I rebuilt the docs, I accidentally changed the "chunk section depth" on the docs -- meaning, the section level that creates the HTML page. If I change that, the server-properties.html page will exist. I am rebuilding that now, and a new version should be on the docs site in a couple of hours.

2. The URL itself is improperly formatted. The link is....
server-properties.html-DatabaseConnectionURL

But that's not right. It should be...
server-properties.html#DatabaseConnectionURL

Even if I fix the page, it's possible the link still won't work because it's not properly formatted.
Comment 3 John Mazzitelli 2012-05-23 13:17:59 EDT
git commit to MASTER: f053977

this doesn't fix this issue, but...

the korean and chinese i18n props files had the help url props in them. No need to do this since these aren't really strings that need translation and if we ever change these url fragments (which we need to in this bz), we need to not only change the java code that produces the default message .props but we would then have to remember to change these
files. Taking these out won't break anything since those languages will not have these props in their own .props file thus will fallback to the default messages props file which WILL have them (they are autogenerated by the java code)
Comment 5 Deon Ballard 2012-05-23 13:23:56 EDT
I have a workaround, since the wiki requires the "-" to be appended to the end of the server.props URL.

If the JON link is set to...

http://docs.redhat.com/docs/en-US/JBoss_Operations_Network/3.1/html/Admin_Configuring_JON_Servers_and_Agents/server-properties.html#

With the # sign at the end, I *think* it will create a URL like...

server-properties.html#-DatabaseConnectionURL

In that case, it just goes to the top of server-properties.html. 

It's not a direct link, but it also doesn't return a 404, so that's something.
Comment 6 John Mazzitelli 2012-05-23 17:29:05 EDT
git commit to MASTER 5dce85d will now no longer require the "-" as a prefix to each startup property. As long as the anchor labels are the same (i.e. the string after each "-"), we can change the doc root to whatever JON uses and it should work.
Comment 7 John Mazzitelli 2012-05-25 11:30:12 EDT
git commit to the jon release/3.1.x branch: 33b2cd764979b2f38a7a787308b7d59669523639
Comment 8 John Mazzitelli 2012-05-25 11:32:53 EDT
I need to cherry pick rhq master 5dce85d and f053977 to rhq release/3.1.x which is needed for the links
Comment 9 John Mazzitelli 2012-05-25 11:37:28 EDT
(In reply to comment #8)
> I need to cherry pick rhq master 5dce85d and f053977 to rhq release/3.1.x
> which is needed for the links

Actually, I only needed to cherry pick rhq master's 5dce85d (the other one only dealt with non-english i18n files, and since the jon 3.1 won't support those, no need for that commit).

I did cherry pick the other since it had a change to the I18N resource keys (we strip out the hardcoded "-" character). That is rhq release/jon3.1.x branch commit 74928ec
Comment 10 Charles Crouch 2012-05-25 14:16:53 EDT
Setting to MODIFIED, this will be in ER6
Comment 11 John Mazzitelli 2012-05-30 16:56:01 EDT
another commit to the 3.1.x branch: 30ed86d9460fdaa8ab4b51343c6e7309be087376

fixes the drift doc link
Comment 12 John Mazzitelli 2012-05-30 17:20:32 EDT
(In reply to comment #11)
> another commit to the 3.1.x branch: 30ed86d9460fdaa8ab4b51343c6e7309be087376
> 
> fixes the drift doc link

the master commit for this fix is: 55d5002e7be3ce85af0b7e39edacbec95a62806a
Comment 13 John Mazzitelli 2012-05-30 17:22:38 EDT
(In reply to comment #12)
> (In reply to comment #11)
> > another commit to the 3.1.x branch: 30ed86d9460fdaa8ab4b51343c6e7309be087376
> > 
> > fixes the drift doc link
> 
> the master commit for this fix is: 55d5002e7be3ce85af0b7e39edacbec95a62806a

someone put the voodoo on me for this BZ. when I committed this, I put the wrong BZ # in the commit message (826715).
Comment 14 John Sanda 2012-06-05 10:39:33 EDT
Moving to ON_QA since this is included in the CR2 build.
Comment 15 Filip Brychta 2012-06-06 06:19:21 EDT
Verified on 3.1.0.CR3

Note You need to log in before you can comment on or make changes to this bug.