Bug 823861 - console=ttyS0 is not added to grub.cfg after serial console installation
console=ttyS0 is not added to grub.cfg after serial console installation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Sivák
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-05-22 06:33 EDT by Kamil Páral
Modified: 2012-05-24 22:00 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-17.29-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-24 22:00:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-05-22 06:33:42 EDT
Description of problem:
I just installed F17 RC3 DVD i386 while adding "console=ttyS0" boot option, following this test case:
https://fedoraproject.org/wiki/QA:Testcase_Anaconda_User_Interface_serial_console

I was using KVM and selected minimal installation. The installation went fine over serial console, but the installed system does not contain "console=ttyS0" in grub.cfg, therefore it is not possible to access the newly installed system over serial console. Also the grub menu itself is not displayed over serial console.

Version-Release number of selected component (if applicable):
F17 RC3 DVD i386
anaconda 17.28

How reproducible:
always

Steps to Reproduce:
1. follow the linked test case
Comment 1 Kamil Páral 2012-05-22 06:34:51 EDT
Marking as F17 Blocker:
The installer must be able to complete an installation using the serial console interface
https://fedoraproject.org/wiki/Fedora_17_Beta_Release_Criteria
Comment 2 Kamil Páral 2012-05-22 06:39:49 EDT
I have found out that if I use "serial console=ttyS0" boot options, anaconda behaves fine - grub menu is displayed over serial console and grub.cfg menu items contain console=ttyS0 option.

But "serial" boot option is deprecated, this is displayed during boot:
dracut Warning: 'serial' is deprecated and has been removed.
dracut Warning: To change the console use 'console=' instead.

Two options here:
1. Re-introduce "serial" keyword in http://fedoraproject.org/wiki/Anaconda_Boot_Options and modify dracut not to spit out that warning
-or-
2. Fix anaconda to correctly set up grub even if "serial" boot option is not present, just "console=ttyS0" is.
Comment 3 Martin Sivák 2012-05-22 09:58:57 EDT
Fix commited to F17 branch and will appear in the next anaconda build.
Comment 4 Fedora Update System 2012-05-22 12:32:07 EDT
anaconda-17.29-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.29-1.fc17
Comment 5 Adam Williamson 2012-05-22 13:56:22 EDT
+1 blocker per criterion, the intention is that doing a serial install as per documentation should work. Adjusting the documentation to match the behaviour is possible, but a bit icky, and we have time for a respin. The respin shouldn't invalidate results from other tests.
Comment 6 Kevin Fenzi 2012-05-22 14:53:37 EDT
+1 blocker. As long as this fix is isolated, seems good to me to respin.
Comment 7 Sandro Mathys 2012-05-22 14:58:49 EDT
+1 blocker as the fix is simple enough not to break too many other things at the same time and there's enough time left for a new RC. Otherwise I'd have gone with +1 NTH instead and CommonBugs/de-deprecate "serial" in anaconda docs, since that used to be the way to go in earlier version and most people wouldn't notice the bug because of that, anyway.
Comment 8 Adam Williamson 2012-05-22 15:14:41 EDT
tflink and bcl were +1 blocker in IRC, so that's +5: accepted.
Comment 9 Dennis Gilmore 2012-05-22 16:05:20 EDT
+1 to blocker sadly
Comment 10 Kamil Páral 2012-05-23 09:59:29 EDT
F17 RC4 fixed this.
Comment 11 Fedora Update System 2012-05-24 22:00:31 EDT
anaconda-17.29-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.