Bug 823871 - Kernel corrupts filesystem when hibernating/resuming
Kernel corrupts filesystem when hibernating/resuming
Status: CLOSED DUPLICATE of bug 822071
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2012-05-22 07:00 EDT by admin
Modified: 2012-07-03 10:33 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-03 10:33:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
cuted yum output with updateing system after hibernating. (1.67 KB, text/plain)
2012-05-24 01:42 EDT, admin
no flags Details
lspci output (1.44 KB, text/plain)
2012-05-24 01:43 EDT, admin
no flags Details
smart -a /dev/sda (5.37 KB, text/plain)
2012-05-24 01:44 EDT, admin
no flags Details
Current dmesg (137.97 KB, text/plain)
2012-05-24 01:44 EDT, admin
no flags Details
fstab (596 bytes, text/plain)
2012-05-24 01:45 EDT, admin
no flags Details

  None (edit)
Description admin 2012-05-22 07:00:15 EDT
Description of problem:
After resume from hibernate new files cannot be create on the file system.  Applications crash that get failed file create failures. 


Version-Release number of selected component (if applicable):
3.3.6-3.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. Hibernate /resume
 
  
Actual results:
corrupt ext4-filesystem

Expected results:
clean filesystem

Additional info:
Apr 24 23:47:12 raistlin kernel: [73046.432511] EXT4-fs error (device dm-1) in ext4_new_inode:941: IO failure
Apr 25 10:45:16 raistlin kernel: [84477.960996] EXT4-fs error (device dm-1): ext4_mb_generate_buddy:739: group 33, 9387 clusters in bitmap, 9370 in gd
Apr 25 12:00:01 raistlin kernel: [88963.464862] EXT4-fs error (device dm-1): mb_free_blocks:1348: group 289, block 9484863:freeing already freed block (bit 14911)
Apr 25 12:00:01 raistlin kernel: [88963.464881] EXT4-fs error (device dm-1): mb_free_blocks:1348: group 289, block 9484864:freeing already freed block (bit 14912)
Apr 25 12:00:01 raistlin kernel: [88963.466580] EXT4-fs error (device dm-1): mb_free_blocks:1348: group 33, block 1090199:freeing already freed block (bit 8855)
Apr 25 12:00:01 raistlin kernel: [88963.466598] EXT4-fs error (device dm-1): mb_free_blocks:1348: group 33, block 1090208:freeing already freed block (bit 8864)
Apr 25 12:01:02 raistlin kdm: :0[31325]: Fatal X server IO error: Interrupted system call
Apr 25 12:03:56 raistlin NetworkManager[595]: <warn> bluez error getting default adapter: Unit dbus-org.bluez.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.bluez.service' for details.
Apr 25 12:04:21 raistlin NetworkManager[595]: <error> [1335330261.463848] [nm-supplicant-interface.c:804] interface_add_cb(): (wlan0): error adding interface: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Apr 25 18:37:27 raistlin NetworkManager[580]: <error> [1335353847.945619] [nm-supplicant-interface.c:804] interface_add_cb(): (wlan0): error adding interface: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Apr 26 09:20:56 raistlin kernel: [ 2692.846667] EXT4-fs error (device dm-1): ext4_mb_generate_buddy:739: group 305, 21221 clusters in bitmap, 21220 in gd
Apr 26 09:20:57 raistlin kernel: [ 2694.677194] EXT4-fs error (device dm-1) in ext4_new_inode:941: IO failure
Apr 26 09:21:10 raistlin dbus-daemon[653]: (upowerd:1084): UPower-WARNING **: failed to set data: Failed to create file '/var/lib/upower/history-rate-AL10B31-48.dat.PJQ2CW': Input/output error
Apr 26 09:21:19 raistlin kernel: [ 2716.181956] EXT4-fs error (device dm-1) in ext4_new_inode:941: IO failure
Apr 26 09:22:01 raistlin kernel: [ 2758.409292] EXT4-fs error (device dm-1): ext4_mb_generate_buddy:739: group 291, 23516 clusters in bitmap, 23515 in gd
Apr 26 09:22:33 raistlin nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/04-iscsi' exited with error status 1.
Apr 26 09:48:53 raistlin kernel: [ 4370.667931] EXT4-fs error (device dm-1) in ext4_new_inode:941: IO failure
Apr 26 09:50:18 raistlin kernel: [ 4454.833845] EXT4-fs error (device dm-1) in ext4_new_inode:941: IO failure
Apr 26 09:50:19 raistlin kernel: [ 4456.732290] EXT4-fs error (device dm-1) in ext4_new_inode:941: IO failure
Apr 26 09:51:06 raistlin kernel: [ 4503.110715] EXT4-fs error (device dm-1) in ext4_new_inode:941: IO failure
Apr 26 09:51:06 raistlin kernel: [ 4503.565660] EXT4-fs error (device dm-1) in ext4_new_inode:941: IO failure
Apr 26 09:51:12 raistlin kernel: [ 4508.913964] EXT4-fs error (device dm-1) in ext4_new_inode:941: IO failure
Apr 26 09:51:48 raistlin kernel: [ 4545.544151] EXT4-fs error (device dm-1) in ext4_new_inode:941: IO failure
Comment 1 Dave Jones 2012-05-22 14:07:08 EDT
please attach the full output of dmesg after a resume. This seems to be just a partial log.

The IO errors seem to suggest some sort of problem reinitialising your storage controller.

(I'm assuming the drive passes a SMART test/badblocks test ?)
Comment 2 admin 2012-05-23 11:08:26 EDT
Yes, drive passes all tests. I will attach requested info withi 2 hours. See bug https://bugzilla.redhat.com/show_bug.cgi?id=822071 - it's the same problem. I think, this bugs are duplicate.
Comment 3 admin 2012-05-24 01:41:04 EDT
I'm attached details. Yesterday I'm corrupted my system with this bug, with yum updating after hibernating my netbook. It was unbootable and I just reinstalled system. now I'm reproduced this bug, see attachments.
Comment 4 admin 2012-05-24 01:42:23 EDT
Created attachment 586544 [details]
cuted yum output with updateing system after hibernating.
Comment 5 admin 2012-05-24 01:43:16 EDT
Created attachment 586545 [details]
lspci output
Comment 6 admin 2012-05-24 01:44:03 EDT
Created attachment 586546 [details]
smart -a /dev/sda
Comment 7 admin 2012-05-24 01:44:34 EDT
Created attachment 586547 [details]
Current dmesg
Comment 8 admin 2012-05-24 01:45:18 EDT
Created attachment 586548 [details]
fstab
Comment 9 Reartes Guillermo 2012-05-30 19:17:19 EDT
When your systems perform a resume, i see:

ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata1.00: unexpected _GTF length (4)
ata1.00: unexpected _GTF length (4)
ata1.00: configured for UDMA/133
sd 0:0:0:0: [sda] Starting disk

http://lwn.net/Articles/202300/

_GTF is an acpi method that is used to reinitialize the drive.  It returns
a task file containing ata commands that are sent back to the drive to restore
it to boot up defaults.

Maybe you can try with this kernel parameter: libata.noacpi=1

Are you using mbr or gpt partitions?

Can you post:
# lspci -vvv
# lspci -k
# lspci -t

# smartctl -x /dev/sda
Maybe before and after suspend, just in case. ( -x Prints all SMART and non-SMART information about the device).
Comment 10 Claudio Guirunas 2012-06-03 17:04:57 EDT
HP Pavilion DV7 suspend fail:
When I click in suspend button, my computer enter in suspend mode and him turn off.
I cant turn on my computer again.
To solve problem, I have that disconnect power charge battery and remove battery and put again.
Comment 11 Adam Williamson 2012-06-04 13:57:47 EDT
Claudio: that's nothing at all to do with this bug.
Comment 12 Matt Olson 2012-06-05 19:55:49 EDT
It's been a week and no progress on this bug.  admin@hostace.ru, any more data?
Comment 13 info 2012-06-28 03:13:39 EDT
This definitely seems to be duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=822071 .
Comment 14 Josh Boyer 2012-07-03 10:33:51 EDT

*** This bug has been marked as a duplicate of bug 822071 ***

Note You need to log in before you can comment on or make changes to this bug.