Bug 823885 - virt-make-fs cannot create vfat filesystem containing filesystems with chinese characters
virt-make-fs cannot create vfat filesystem containing filesystems with chines...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 07:34 EDT by Richard W.M. Jones
Modified: 2012-05-24 22:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-24 09:42:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-05-22 07:34:02 EDT
Description of problem:

$ mkdir testdata
$ touch testdata/马磊
$ sudo chown -R root.root testdata   # workaround for bug 584228
$ virt-make-fs -t vfat --partition=mbr testdata disk.img
Formatting 'disk.img', fmt=raw size=292864 
virt-make-fs: error copying contents into filesystem
An error here usually means that the program did not estimate the
filesystem size correctly.  Please read the BUGS section of the manpage.
tar_in: tar subcommand failed on directory: /: tar: ./\351\251\254\347\243\212: Cannot open: Invalid argument
tar: Exiting with failure status due to previous errors at /usr/bin/virt-make-fs line 512, <PIPE> line 1.

Version-Release number of selected component (if applicable):

1.18.0

How reproducible:

100%

Steps to Reproduce:
1. See above.
Comment 1 Richard W.M. Jones 2012-05-24 09:42:13 EDT
Worked around by adding utf8 option in virt-make-fs
(commit d5d9ceee8b56a10761e207ad9970ebf704fc46e8).

Note You need to log in before you can comment on or make changes to this bug.