Bug 823916 - Need to update virt-viewer man page
Need to update virt-viewer man page
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
: ManPageChange
Depends On: 1179477
Blocks: 921341
  Show dependency treegraph
 
Reported: 2012-05-22 08:54 EDT by yuping zhang
Modified: 2016-04-26 11:27 EDT (History)
12 users (show)

See Also:
Fixed In Version: virt-viewer-2.0-1.el6
Doc Type: Bug Fix
Doc Text:
No doc needed
Story Points: ---
Clone Of:
: 921341 (view as bug list)
Environment:
Last Closed: 2015-07-22 02:30:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description yuping zhang 2012-05-22 08:54:54 EDT
Description of problem:
1.No man page for --display option in #man virt-viewer
  --display=DISPLAY                                                 X display to use

2.No man page for --display and --direct options in #man remote-viewer
 -d, --direct                                                      Direct connection with no automatic tunnels
 --display=DISPLAY                                                 X display to use

3.No man page for Spice Options both #man virt-viewer and #man remote-viewer
Spice Options:
  --spice-disable-effects=<wallpaper,font-smooth,animation,all>     Disable guest display effects
  --spice-color-depth=<16,32>                                       Guest display color depth
  --spice-ca-file=<file>                                            Truststore file for secure connections
  --spice-host-subject=<host-subject>                               Subject of the host certificate (field=value pairs separated by commas)
  --spice-disable-audio                                             Disable audio support
  --spice-smartcard                                                 Enable smartcard support
  --spice-smartcard-certificates=<certificates>                     Certificates to use for software smartcards (field=values separated by commas)
  --spice-smartcard-db=<certificate-db>                             Path to the local certificate database to use for software smartcard certificates
  --spice-disable-usbredir                                          Disable USB redirection support
  --spice-usbredir-filter=<filter-string>                           Filter for excluding USB devices from auto redirection
  --spice-cache-size=<bytes>                                        Image cache size
  --spice-glz-window-size=<bytes>                                   Glz compression history size
  --spice-debug                                                     Enable Spice-GTK debugging
  --spice-gtk-version                                               Display Spice-GTK version information

4.The Copyright need to update in virt-viewer man page.
#man virt-viewer
COPYRIGHT
       Copyright (C) 2007-2008 Red Hat, Inc., and various contributors.

5.No punctuation before "The viewer can connect.."
#man virt-viewer
...
DESCRIPTION
       virt-viewer is a minimal tool for displaying the graphical console of a virtual machine. The console is accessed using the VNC or
       SPICE protocol. The guest can be referred to based on its name, ID, or UUID. If the guest is not already running, then the viewer
       can be told to wait until is starts before attempting to connect to the console The viewer can connect to remote hosts to lookup
       the console information and then also connect to the remote console using the same network transport.
....

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-9.el6.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 4 CongDong 2013-10-29 05:14:51 EDT
I can reproduce the bug with:
virt-viewer-0.5.6-8.el6.x86_64

Steps:
# man virt-viewer

Result:
1. Same with the description
2. Another problem:
...
DESCRIPTION
...then the viewer
       can be told to wait until is starts before attempting to connect to the console
...

The word "is" after until should be "it".
Comment 5 Marc-Andre Lureau 2013-12-10 18:28:59 EST
--display is not a virt-viewer specific option, hence it should not be documented by virt-viewer man page (otherwise we'd need to patch all the man pages of all gtk+ programs).

Same for
--spice-*

Why is it worth updating copyright date everytime a minor modification is made?
Comment 8 Jonathon Jongsma 2015-03-02 11:42:58 EST
rebased to release 2.0 which should have an updated man page.
Comment 10 tingting zheng 2015-03-03 03:01:15 EST
Tested with:
virt-viewer-2.0-2.el6.x86_64

Steps:
1.Check in virt-viewer --help and manual,--direct option is included in both:
# man virt-viewer 
       -d, --direct
           Do not attempt to tunnel the console over SSH, even if the main connection URI used SSH.

# virt-viewer --help

  -d, --direct                                                      Direct connection with no automatic tunnels

2.Check virt-viewer manual,punctuation has been added before "The viewer can connect.."

3.Check issue in comment 4,the word "is" after until has been changed to "it".
# man virt-viewer
……
then the viewer can be told to wait until it starts before attempting to connect to the console.

Refer to the above comments,move the bug to VERIFIED.
Comment 13 errata-xmlrpc 2015-07-22 02:30:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1322.html

Note You need to log in before you can comment on or make changes to this bug.