Bug 823926 - Rebase krb5 to 1.10 for AD trust to work
Rebase krb5 to 1.10 for AD trust to work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: krb5 (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Nalin Dahyabhai
Zbysek MRAZ
: Rebase
Depends On:
Blocks: 791327
  Show dependency treegraph
 
Reported: 2012-05-22 09:13 EDT by Dmitri Pal
Modified: 2013-07-03 09:15 EDT (History)
7 users (show)

See Also:
Fixed In Version: krb5-1.10.3-5.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:37:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2012-05-22 09:13:42 EDT
Krb5 needs to be updated to 1.10 to deliver AD trust functionality.
Comment 2 Nalin Dahyabhai 2012-07-05 14:06:22 EDT
Simo, Sumit, can one of you elaborate on which changes after 1.9(.0) were needed for this?  I'm trying to enumerate a list, and going from the README files, tickets 6869, 6886, 6912, 6994/7007, 7016/7039, 7092/7102, and 7120/7142 look relevant.  We already backported some of those into the earlier update, though, and if we can backport the rest and avoid a complete rebase, I'd prefer it.
Comment 3 Simo Sorce 2012-07-06 11:45:19 EDT
From IRC:
<simo> nalin: all testing have been done with 1.10, we have no idea how to isolate only the necessary changes
<nalin> simo: is 1.9 even known to not work, then?
<simo> yes
<simo> 1.9 will NOT work
<nalin> because...?
<simo> changes in internal interfaces iirc, plus number of bugs, plus we didn't bother finding out what else
Comment 4 RHEL Product and Program Management 2012-07-10 04:16:11 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 19:59:52 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 15 errata-xmlrpc 2013-02-21 03:37:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0319.html

Note You need to log in before you can comment on or make changes to this bug.