Bug 82394 - (savage/mx) fails to display screen as expected on ibm t21
(savage/mx) fails to display screen as expected on ibm t21
Status: CLOSED DUPLICATE of bug 80346
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 79579 82788
  Show dependency treegraph
 
Reported: 2003-01-21 15:30 EST by Kaj J. Niemi
Modified: 2008-01-17 12:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config from working XF86 4.2.0 installation (3.30 KB, text/plain)
2003-01-21 15:32 EST, Kaj J. Niemi
no flags Details
XFree86 log w/ savage_drv = 1.1.26 (XFree86 default), non working version (34.30 KB, text/plain)
2003-01-22 09:15 EST, Kaj J. Niemi
no flags Details
XFree86 log w/savage_drv = 1.1.27 (manually installed), working version (35.37 KB, text/plain)
2003-01-22 09:16 EST, Kaj J. Niemi
no flags Details

  None (edit)
Description Kaj J. Niemi 2003-01-21 15:30:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; .NET 
CLR 1.0.3705)

Description of problem:
When using existing (flawlessly working) XF86 4.2.0 XF86Config on the same IBM 
T21 (2647-9AG, 850 MHz Pentium 3, 384 MB memory) laptop phoebe (and rawhide, 
actually) XFree86 fail to display anything intelligent at a resolution of 
1400x1050 (or any other resolution I tried (1024x768, 800x600) except 640x480.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install phoebe's XFree86
2. Copy attached XF86Config 
3. startx
    

Actual Results:  Screen is unstable and most people would agree it's not 
something anybody would want to work with.

Expected Results:  Should not show any fuzz, wavering or funny extra 
hardware/software cursors on the screen. Picture should be stable.

Additional info:

Must have been broken somewhere after 4.2.0 release (in RH8)
Seems like there's a new savage driver (1.26?) as well.
Comment 1 Kaj J. Niemi 2003-01-21 15:32:25 EST
Created attachment 89488 [details]
XF86Config from working XF86 4.2.0 installation
Comment 2 petrosyan 2003-01-21 17:18:20 EST
I had similar experiences on Thinkpad T20 (all previos version of RH worked fine ).

going to 16 bit depth from 24 solved my problem.
I think that fuzziness comes because for some strange reason it does not have
enough bandwidth.

Try a modeline which has _lower_ refresh rate. It could solve the problem.
Comment 3 Kaj J. Niemi 2003-01-21 18:15:06 EST
I was attempting to run at 16 bpp, not 24.

Could you attach a working post-4.2.0 XF86Config to play around with? The T20 is
pretty much identical to a T21 (and a T22) thanks :)

redhat-config-xfree86 --reconfig doesn't really help at all but then again
Xconfigurator didn't help either once upon a time...
Comment 4 petrosyan 2003-01-22 02:53:00 EST
My X Window setup was very buggy and I upgraded to 1.1.27t drivers and all the
problems went away.
http://www.probo.com/timr/xf42sav-27t.tgz
make sure also to copy the libraries.

I suspect that the problem is that for some strange reason the new drivers use
BIOS to set the video mode, while the old drivers used to say that they are not
using BIOS.

Could you please attach your X server log file ? (/var/log/XFree86.0.log )

Comment 5 Kaj J. Niemi 2003-01-22 09:08:44 EST
Thanks for the tip! All problems disappear when using savage_drv 1.1.27t.

Did the following:
       
  mkdir /tmp/foo
  cd /tmp/foo
  tar xzf /tmp/xf42sav-27t.tgz
                                                                                
  cp /usr/X11R6/lib/modules/linux/libint10.a /usr/X11R6/lib/modules/linux/libint
10.a-old
  cp libint10.a /usr/X11R6/lib/modules/linux/libint10.a
                                                                                
  cp /usr/X11R6/lib/modules/libvbe.a /usr/X11R6/lib/modules/libvbe.a-old
  cp libvbe.a /usr/X11R6/lib/modules/libvbe.a
                                                                                
  cp /usr/X11R6/lib/modules/drivers/savage_drv.o /usr/X11R6/lib/modules/drivers/
savage_drv.o-old
  cp savage_drv.o /usr/X11R6/lib/modules/drivers/savage_drv.o
                                                                                
Attached is a copy of XFree86.log with savage_drv version 1.1.27 and a
non-working one with savage_drv version 1.1.26.

Granted the workaround breaks RPMability a bit but perhaps somebody would
include 1.1.27 in the next RH release of XFree86? I guess 1.1.26 came along from
XFree86 CVS.
Comment 6 Kaj J. Niemi 2003-01-22 09:15:28 EST
Created attachment 89517 [details]
XFree86 log w/ savage_drv = 1.1.26 (XFree86 default), non working version
Comment 7 Kaj J. Niemi 2003-01-22 09:16:38 EST
Created attachment 89518 [details]
XFree86 log w/savage_drv = 1.1.27 (manually installed), working version
Comment 8 petrosyan 2003-01-22 10:06:57 EST
If you compare the two log files that you have attached, ( btw, my log files
also look the same ), you will see one big difference:
savage_drv version 1.1.26:
(EE) SAVAGE(0): Failed to fetch any BIOS modes.  Disabling BIOS.
...
II) SAVAGE(0): VESA BIOS detected
(II) SAVAGE(0): VESA VBE Version 2.0
(II) SAVAGE(0): VESA VBE Total Mem: 8192 kB
(II) SAVAGE(0): VESA VBE OEM: S3 Incorporated. M7 BIOS
(II) SAVAGE(0): VESA VBE OEM Software Rev: 1.0
(II) SAVAGE(0): VESA VBE OEM Vendor: S3 Incorporated.
(II) SAVAGE(0): VESA VBE OEM Product: VBE 2.0
(II) SAVAGE(0): VESA VBE OEM Product Rev: Rev 1.1
(--) SAVAGE(0): mapping framebuffer @ 0xf0000000 with size 0x800000
(==) SAVAGE(0): Write-combining range (0xf0000000,0x800000)
(II) SAVAGE(0): Using 997 lines for offscreen memory.
(II) SAVAGE(0): Using XFree86 Acceleration Architecture (XAA)

savage_drv version 1.1.27:

(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Reloading /usr/X11R6/lib/modules/linux/libint10.a
(II) SAVAGE(0): initializing int10
(II) SAVAGE(0): Primary V_BIOS segment is: 0xc000
(II) SAVAGE(0): VESA BIOS detected
(II) SAVAGE(0): VESA VBE Version 2.0
(II) SAVAGE(0): VESA VBE Total Mem: 8192 kB
(II) SAVAGE(0): VESA VBE OEM: S3 Incorporated. M7 BIOS
(II) SAVAGE(0): VESA VBE OEM Software Rev: 1.0
(II) SAVAGE(0): VESA VBE OEM Vendor: S3 Incorporated.
(II) SAVAGE(0): VESA VBE OEM Product: VBE 2.0
(II) SAVAGE(0): VESA VBE OEM Product Rev: Rev 1.1
(--) SAVAGE(0): mapping framebuffer @ 0xf0000000 with size 0x800000
(==) SAVAGE(0): Write-combining range (0xf0000000,0x800000)
(--) SAVAGE(0): Chose mode 13c at 60Hz.
(II) SAVAGE(0): Using 997 lines for offscreen memory.
(II) SAVAGE(0): Using XFree86 Acceleration Architecture (XAA)


You can see that 1.1.27 used the so called mode 13c in your case, while 1.1.26
disabled the BIOS.

I suspect that to be the problem, but I am not sure.

Does Mike have any ideas ?
Comment 9 Kaj J. Niemi 2003-01-22 11:17:13 EST
Yup, not knowing much about X programming I'd inclined to agree that there's
been some important changes in 1.1.26 and 1.1.27 (changelog doesn't seem to
exist on the author's site?)

Perhaps RedHat would compile and include 1.1.27 instead of the version that
comes with XFree86 in the next release?
Comment 10 Mike A. Harris 2003-01-23 01:07:43 EST
I'm willing to investigate this 1.1.27t driver, but there is no source
code on Tim's website for it currently.  Until the source code and
changelog are up on the web site, I'm unable to investigate this however.

I mailed Tim earlier today though, so perhaps this is newer than what
he's got up for download.
Comment 11 Kaj J. Niemi 2003-01-23 07:37:24 EST
Found the release notes, 1.1.27t is a preview/test release.
<http://probo.probo.com/pipermail/savage40/2003-January/000032.html>
Comment 12 Mike A. Harris 2003-01-23 08:34:59 EST
Thanks.

Can you also look at bug #80346 and comment on wether you think it sounds
like the same issue?
Comment 13 Kaj J. Niemi 2003-01-23 09:42:08 EST
It sure sounds like a similar problem.
Comment 14 Mike A. Harris 2003-01-24 01:06:43 EST

*** This bug has been marked as a duplicate of 80346 ***
Comment 15 Red Hat Bugzilla 2006-02-21 13:51:17 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.