This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 823992 - Packages built against Fedora 17 glib do not have correct dependencies
Packages built against Fedora 17 glib do not have correct dependencies
Status: ASSIGNED
Product: Fedora
Classification: Fedora
Component: glib2 (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 10:41 EDT by David Woodhouse
Modified: 2015-07-15 11:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-04 22:51:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 676565 None None None Never

  None (edit)
Description David Woodhouse 2012-05-22 10:41:52 EDT
I recently tried to update my Fedora 16 with just one or two new packages from Fedora 17, because some important bug fixes hadn't been backported.

These packages require glib, and use new symbols which were only added in glib 2.31.

But their dependencies are not correct. They *should* require
libglib-2.0.so.0(GLIB_2.31)(64bit) but instead they only require
libglib-2.0.so.0(64bit) without the version.

This means that the new packages happily install alongside the old version of glib, and then fail at runtime because of their unmet dependencies.

This is because glib itself is built without versioned symbols. If that were fixed, the packages which link against it would pick up *correct* dependencies.
Comment 1 Matthias Clasen 2012-05-22 22:38:47 EDT
glib doesn't use symbol versions, and it doesn't want to either.
Comment 2 David Woodhouse 2012-05-23 04:18:16 EDT
Hm, I hadn't thought to look for previous discussion; it seems like such an obviously correct thing to do to fix a real problem, that I'm surprised anyone would not want to do it; I assumed it had just never been considered or a patch had never been provided.

Looking now at some of the discussion, the 'no' camp doesn't seem to be particularly well-informed...

- libxml2 seems to be used as an example of why symbol versioning is bad, 
  because AFAICT it did something insanely broken (using symbol versions and 
  then taking them *out* in release versions, or something like that?). That
  is not what I mean when I refer to symbol versioning. That is just complete 
  crack; do not use that as an example of anything.

- I see complaints that it doesn't allow you to version structures and other 
  things, which is both incorrect and not necesarily relevant. Firstly, it 
  *does* let you version structures. The canonical example of symbol
  versioning is its use in glibc to handle changes to 'struct stat'. And 
  secondly, it doesn't have to solve every problem in the world — complaining 
  that it won't cure AIDS is pointless. It solves the problem it's intended
  to solve, quite well.

- I see complaints that it doesn't work on every platform. Which is also fine.
  It doesn't *hurt* any of the few platforms that don't support it. It *does*
  work on any platform which uses the GNU linker (or gold), and Solaris.

- I see complaints that it can't cope with incompatibilities for which we
  really *do* need to be changing the soname of the library rather than
  attempting to claim backward compatibility anyway (like changing 
  non-opaque structures that are embedded in users' own variables such
  as GtkWidget).
  Unless I'm misreading that, and in fact it was a complaint that it would
  be impractical to provide full backward compatibility in that case, by using
  symbol versions to provide "old" versions of every function that touches
  something like GtkWidget — which of course isn't something I'd suggest
  attempting anyway.

Did I miss anything?
Comment 3 Fedora End Of Life 2013-07-03 20:21:20 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2013-07-31 23:57:51 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 5 David Woodhouse 2013-08-01 03:19:30 EDT
Still not fixed. Still no good reason not to fix it other then "libxml did something insane and now we think symbol versioning has cooties"
Comment 6 Matthias Clasen 2014-09-04 22:51:43 EDT
It is not going to get fixed. I don't think there's a point in keeping this bug around.
Comment 7 David Woodhouse 2014-09-05 04:33:39 EDT
I put in the effort to find existing discussions and attempt to make sense of them, and I would appreciate a substantive response to comment 2 rather than a simple "no, we *want* this to be broken".
Comment 8 Jan Kurik 2015-07-15 11:08:40 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 23 development cycle.
Changing version to '23'.

(As we did not run this process for some time, it could affect also pre-Fedora 23 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 23 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora23

Note You need to log in before you can comment on or make changes to this bug.