Bug 8240 - The systems assigns itself a wrong IP #
The systems assigns itself a wrong IP #
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-06 15:35 EST by jack
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-17 16:53:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jack 2000-01-06 15:35:00 EST
Within the ifcfg-eth0 file the machine is assigned an ip number lets say
x.x.165.5, after the system loads ifcfg-eth0 & several alias files
ifcfg-eth0:1 - ifcfg-eth0:15 and you run ifconfig it reports back that the
ifcfg-eth0 is the x.x.165.5 ip number as expected, and those other alias
files as well.

Now here is the problem, when you telnet from this machine into another
computer, that computer sees your IP number as x.x.165.43 and not
x.x.165.5.

The ip number it is acting as is one of the valid alias IP numbers, but is
*not* the one we assign to the machine.  If I manipulate the ifcfg-eth0:1
-
ifcfg-eth0:15 filenames so that a different ip number is contained within
lets say ifcfg-eth0:1 it then thinks that, that is the ip number for the
machine again istead of x.x.165.5.

The problem of course is that we restrict security to our other linux
servers by IP number, and since this IP number is wrong we can't access
our
other servers.  One footnote is that if you ping or query the proper ip
number, that works, it's just when you telnet or ftp from the console into
an other system that it sees it wrong.
Comment 1 Ben LaHaise 2000-02-17 16:53:59 EST
What netmask are you adding the aliases with?  It sounds like the aliases are
being added with the same netmask as the rest of the network instead of
255.255.255.255, which will lead to a network route being installed for each
alias that overrides the default netmask.

Note You need to log in before you can comment on or make changes to this bug.