Bug 824019 - [as7] check that server's basedir has not changed since discovery needs to be added to server components' start() method
[as7] check that server's basedir has not changed since discovery needs to be...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.4
Unspecified Unspecified
urgent Severity high (vote)
: ---
: JON 3.1.0
Assigned To: Charles Crouch
Mike Foley
:
Depends On: 823558
Blocks: as7-plugin
  Show dependency treegraph
 
Reported: 2012-05-22 11:08 EDT by Ian Springer
Modified: 2015-02-01 18:28 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 823558
Environment:
Last Closed: 2013-09-04 05:01:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2012-05-22 11:08:50 EDT
+++ This bug was initially created as a clone of Bug #823558 +++

This check is important, because the basedir is the resource key, and so if that changes, it's no longer the same server Resource, and start() should throw a InvalidPluginConfigurationException, which will result in a yellow triangle in the GUI.

We have such a check in the as4 and as5 plugins.

We should also move the launch-type and product-name checks that are currently in getAvailablity() to start().
Comment 1 Charles Crouch 2012-05-22 12:43:24 EDT
I'd like to get this in since it helps prevent user confusion when starting up different servers on the same port. Assuming this has good automated test coverage we should push this to the release/jon3.1.x branch
Comment 5 Heiko W. Rupp 2013-09-04 05:01:43 EDT
Closing for the old release as Bug 823558 has been fixed/implemented and the fixes were cp'd over.

Note You need to log in before you can comment on or make changes to this bug.