Bug 824030 - Fails to connect to wireless when no ipv6 in present
Fails to connect to wireless when no ipv6 in present
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 11:30 EDT by Bill C. Riemers
Modified: 2013-02-13 08:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 08:55:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill C. Riemers 2012-05-22 11:30:31 EDT
Description of problem:

I have two wireless networks in my house.  My primary wireless network is running on TomatoUSB and has IPv6 configured.   My secondary is running an old DD-WRT build and does not have IPv6.

Yesterday, I ran "yum update" on my son's laptop, to install the approximately 1GB of fedora updates since the last time I updated his laptop.   Afterwards, the laptop was able to connect to the main wireless router with IPv6 no problem.  But he was in an area of the house with low signal strength.  When ever he tried to connect the secondary router the connection was instantly dropped.  The /var/log/messages file indicated the connection was dropped but did not report a reason.  Since I had just moved around the routers earlier in they day I spent about an hour debugging the connection.  Eventually the problem occured to me.  I edited the wireless connection settings for that connection from "Automatic" to "Ignored" for IPv6.   After that he was able to connect with no problems.
 

Version-Release number of selected component (if applicable):

0.9.4-3

How reproducible:
100% on his laptop

Steps to Reproduce:
1. Edit the wireless connection and change IPv6 back to Automatic.  (Note: This is the default setting.)
2. Try to connect to the wireless connection.
3.
  
Actual results:

Connection instantly fails.

Expected results:

Since I did not have the IPv6 required box checked, the connection should succeed and run without IPv6.

Additional info:

This is a serious problem, in that it will block users from connecting to the average hotspot, as I've yet to see a hotspot that supports IPv6.   I recently gave a laptop to a friend about 1000 miles away.  If he makes the mistake of running a yum update before this is fixed, his network will be broken, and I will have to try and describe the workaround to him over the phone.  I imagine there are many Fedora users who don't have a friend that can do this for them.

I do not know if this happens on all hardware, or purhaps only with select drivers.  If you need me to collect more information I will be happy to do so.  

There is another bug, where if IPv6 was on automatic the wireless connection would drop every 15 minutes or so.  It seems very likely this bug is a result of the fix for that bug.
Comment 1 Fedora End Of Life 2013-01-16 08:13:32 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Fedora End Of Life 2013-02-13 08:55:34 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.