Bug 824041 - grub2 always chooses newest kernel available as default option
grub2 always chooses newest kernel available as default option
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: grub2 (Show other bugs)
7.0
All Linux
high Severity urgent
: rc
: ---
Assigned To: Peter Jones
Desktop QE
:
Depends On:
Blocks: 1025505
  Show dependency treegraph
 
Reported: 2012-05-22 11:44 EDT by Vladimir Benes
Modified: 2013-12-18 11:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
If Fedora 17 or later is installed on the system, the kernel uses a shared /boot partition, and the user installs Red Hat Enterprise Linux 7.0 Beta which uses the same /boot partition, the latest kernel will be used by GRUB 2. That is, Red Hat Enterprise Linux 7.0 Beta can use a Fedora kernel if this is later, resulting in certain modules to be limited or non-functioning (for example, sound or networking). To work around the problem, the correct kernel must be chosen manually.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 11:16:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2012-05-22 11:44:53 EDT
Description of problem:
when installing rhel7 over f17 and using same boot partition (this seems to be quite common) grub mkconfig choses f17's kernel as default option as it's newer. Then I need to go into advanced option and chose the rhel7 one.
 

Version-Release number of selected component (if applicable):
grub2-2.0.0-27.beta5

How reproducible:
100%

Steps to Reproduce:
1.install F17 or any newer kernel into shared partition 
2.install RHEL7 with option to install grub enabled
3.boot RHEL7 default option
  
Actual results:
wrong plymouth
modules (e.g networking) unavailable
need to go into advance options and chose correct kernel there

Expected results:
correct kernel chosen as default option
Comment 1 Vladimir Benes 2012-05-22 11:51:20 EDT
just to explain more: I installed RHEL7 next to F17 no update.. clean install.. no update
Comment 2 Ludek Smid 2012-06-22 10:38:40 EDT
Could you verify that bug is still valid for RHEL 7.0 Alpha 2?
Comment 3 Vladimir Benes 2012-06-25 07:41:34 EDT
(In reply to comment #2)
> Could you verify that bug is still valid for RHEL 7.0 Alpha 2?
yes, it does!
Comment 5 David Cantrell 2013-10-28 11:44:50 EDT
This is entirely valid, but is the nature of things when dealing with Fedora and RHEL on the same system.  Fedora will almost always have a more recent kernel than RHEL.

I'm moving this out to 'rc' for the target because I don't feel it's really critical for beta.
Comment 6 RHEL Product and Program Management 2013-12-18 11:16:53 EST
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.