Bug 824046 - Incompatible with mcollective 2.0.0
Incompatible with mcollective 2.0.0
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: rubygem-stomp (Show other bugs)
el6
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Michael Stahnke
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 11:54 EDT by Justin Brown
Modified: 2012-11-29 13:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-29 13:04:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Brown 2012-05-22 11:54:43 EDT
Description of problem:

rubygem-stomp is a dependency of mcollective. With mcollective 2.0.0 (current in EPEL), stomp+ssl connectors require >=1.2.0 (current is 1.2.2) of rubygem-stomp.

MCollective will install and start (without a stomp+ssl connector) fine. There are no problems. If a stomp+ssl connector is configured, MCollective refuses to start and throws errors.

It would be helpful if rubygem-stomp could be upgraded to 1.2.2.

Thanks,

Justin
Comment 1 Steve Traylen 2012-05-22 13:16:07 EDT
Looking at the changelog:

https://github.com/stompgem/stomp/blob/master/CHANGELOG.rdoc

its seems to be mostly important bug fixes plus the addition on stomp 1.1
support but 1.0 support is still there.

I'd like to see this to.

I just verified that the 1.2.2 builds okay with out modification beyond
the obvious to the .spec file in el5 and fc16.
Comment 2 Michael Stahnke 2012-05-28 13:45:44 EDT
I'm putting 1.2.2 into Fedora today.  I'll them check and make sure it's all ok before putting it in EPEL. (I work at Puppet Labs, so I am very interested in ensuring mcollective and friends work well with this on EL)
Comment 3 Fedora Update System 2012-05-28 13:47:50 EDT
rubygem-stomp-1.2.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/rubygem-stomp-1.2.2-1.fc17
Comment 4 Fedora Update System 2012-07-02 18:32:53 EDT
rubygem-stomp-1.2.2-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Steve Traylen 2012-09-14 09:11:23 EDT
And el?
Comment 6 Fedora Update System 2012-11-05 00:31:23 EST
rubygem-stomp-1.2.2-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/rubygem-stomp-1.2.2-1.el5
Comment 7 Fedora Update System 2012-11-05 00:31:38 EST
rubygem-stomp-1.2.2-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/rubygem-stomp-1.2.2-1.el6
Comment 8 Fedora Update System 2012-11-29 13:04:39 EST
rubygem-stomp-1.2.2-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-11-29 13:06:41 EST
rubygem-stomp-1.2.2-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.