Bug 824060 - buglist.cgi not handling bug_id properly ... results in empty search results when selecting 'view as bug list' from dependency tree
buglist.cgi not handling bug_id properly ... results in empty search results ...
Status: CLOSED DUPLICATE of bug 824092
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 12:24 EDT by James Laska
Modified: 2014-10-12 18:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-22 18:04:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2012-05-22 12:24:17 EDT
Description of problem:

When looking at a non-empty dependency tree for a bug, selecting 'view as bug list' results in an empty search query.

Version-Release number of selected component (if applicable):
 * 4.2

How reproducible:
 * Pretty darn easy

Steps to Reproduce:
1. Visit the dependencytree for a bug that does blocker other bugs.  At the time of this filing, the Fedora 17 BLocker bug [1] works.  However, that bug will be empty soon.
2. Select 'view as bug list'
  
[1] https://bugzilla.redhat.com/showdependencytree.cgi?id=F17Blocker&hide_resolved=1

Actual results:

Step#2 takes the user to the following page: https://bugzilla.redhat.com/buglist.cgi?bug_id=823861,765956

This page results in an empty search result.

Expected results:

I'd expect to see results for a query such as: https://bugzilla.redhat.com/buglist.cgi?bug_id=823861,765956

Additional info:
Comment 1 Simon Green 2012-05-22 18:04:17 EDT

*** This bug has been marked as a duplicate of bug 824092 ***

Note You need to log in before you can comment on or make changes to this bug.