Bug 824073 - WinSync In FreeIPA 2.2 (2.1.90) Deletes Users matched from AD
WinSync In FreeIPA 2.2 (2.1.90) Deletes Users matched from AD
Status: CLOSED DUPLICATE of bug 818762
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 12:58 EDT by Dmitri Pal
Modified: 2013-03-05 14:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-05 14:51:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2012-05-22 12:58:53 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/2688

Following the document here: https://docs.fedoraproject.org/en-US/Fedora/15/html/FreeIPA_Guide/managing-sync-agmt.html#tab.sync-agmt-attrs

All users who's Active Directory samAccountName matched FreeIPA Uid's had their FreeIPA Uid's and Kerberos Principals deleted...

I double-checked /var/log/slapd-INSTANCE/audit and I can confirm that I see the MemberOf plugin Deleting the users from their previously associated Groups, but I DO NOT see any logs clearly showing the WinSync plugin deleting them.  Ldap searches confirm that the users no longer exist in LDAP OR Kerberos...

Package Versions:
freeipa-server-selinux-2.1.90.rc1-0.fc16.x86_64
freeipa-server-2.1.90.rc1-0.fc16.x86_64
freeipa-admintools-2.1.90.rc1-0.fc16.x86_64
freeipa-client-2.1.90.rc1-0.fc16.x86_64
freeipa-python-2.1.90.rc1-0.fc16.x86_64
389-ds-base-libs-1.2.10.6-1.fc16.x86_64
389-ds-base-1.2.10.6-1.fc16.x86_64
Comment 1 Martin Kosek 2012-11-07 10:19:37 EST
Ticket 2688 was closed as a duplicate of https://fedorahosted.org/freeipa/ticket/2927.

Moving to POST since the issue was already fixed in 389-ds upstream, as a part of 1.2.11.12 release.
Comment 3 Namita Soman 2013-03-05 14:51:11 EST

*** This bug has been marked as a duplicate of bug 818762 ***

Note You need to log in before you can comment on or make changes to this bug.