Bug 824109 - BZ: runQuery fails for some bugs
BZ: runQuery fails for some bugs
Status: CLOSED DUPLICATE of bug 824092
Product: Bugzilla
Classification: Community
Component: WebService (Show other bugs)
4.2
Unspecified Unspecified
urgent Severity urgent (vote)
: ---
: ---
Assigned To: Simon Green
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 14:17 EDT by Tomas Hoger
Modified: 2014-10-12 18:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-22 18:09:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Hoger 2012-05-22 14:17:35 EDT
Description of problem:
runQuery currently fails to return info for some bugs.  This works:

DEBUG: Bugzilla RPC call: bugzilla.runQuery, arguments:
DEBUG: $VAR1 = {
DEBUG:   'bug_id' => '823474'
DEBUG: };

and returns bug info while the same for other bug (that is public, so there should be no permissions issue, this was tried over authenticated connection too):

DEBUG: Bugzilla RPC call: bugzilla.runQuery, arguments:
DEBUG: $VAR1 = {
DEBUG:   'bug_id' => '807252'
DEBUG: };

returns no result:

DEBUG:   ],
DEBUG:   'bugs' => []
DEBUG: };

This was reportedly introduced by BZ update earlier today.
Comment 5 Simon Green 2012-05-22 18:09:23 EDT

*** This bug has been marked as a duplicate of bug 824092 ***

Note You need to log in before you can comment on or make changes to this bug.