Bug 824121 - IPv6: Kernel doesn't propagate DNSSL to userspace (e.g. NetworkManager)
IPv6: Kernel doesn't propagate DNSSL to userspace (e.g. NetworkManager)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 14:59 EDT by Pavel Šimerda (pavlix)
Modified: 2012-12-12 12:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-12 12:02:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pavel Šimerda (pavlix) 2012-05-22 14:59:41 EDT
While NetworkManager recieves RDNSS neighbor discovery user option from kernel, it doesn't recieve DNSSL at all. This can be debugged with NetworkManager
(or hopefully some better testing tool) and radvdump (to check if DNSSL is present).

radvdump reports DNSSL is there, NetworkManager gets no netlink message from kernel.

kernel-3.3.4-4.fc17.x86_64
NetworkManager-0.9.4.0-7.git20120403.fc17.x86_64
Comment 1 Dave Jones 2012-05-22 15:15:55 EDT
your best bet for networking bugs is to contact the upstream developers directly.
netdev@vger.kernel.org
Comment 2 Pavel Šimerda (pavlix) 2012-05-27 09:59:10 EDT
It looks like even 3.4 lacks support for DNSSL, I quickly scanned through the diff.

I hoped I would clean up the list of IPv6 bugs a little bit before World IPv6 Launch:

http://fedoraproject.org/wiki/Tools/NetworkManager/IPv6
http://www.worldipv6launch.org/

My posting to netdev@vger.kernel.org:

http://www.spinics.net/lists/netdev/msg199408.html
Comment 3 Pavel Šimerda (pavlix) 2012-07-26 10:52:22 EDT
Kernel 3.5 will bring DNSSL support.
Comment 4 Pavel Šimerda (pavlix) 2012-12-12 12:02:52 EST
Fixed in 3.5. Using daily. Works.

Note You need to log in before you can comment on or make changes to this bug.