Bug 824148 - Install kernel panics on boot. Oops in pcie_aspm_init_link_state
Install kernel panics on boot. Oops in pcie_aspm_init_link_state
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 16:11 EDT by Eric Hopper
Modified: 2013-01-10 02:45 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 15:00:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A screen capture of the kernel panic (2.71 MB, image/jpeg)
2012-05-22 17:25 EDT, Eric Hopper
no flags Details

  None (edit)
Description Eric Hopper 2012-05-22 16:11:10 EDT
Description of problem:
I'm running Fedora 17 beta and the install kernel panics on bootup. It panics sometime while it's trying to do hardware initialization. I suspect it's the video card.

Version-Release number of selected component (if applicable):
The Fedora 17 x86_64 Beta torrent. Not the Live version.

How reproducible:
Every time I boot from the install DVD I burned, or from the USB stick I created using the 'dd' method.

Steps to Reproduce:
1.Put the disk in
2.Start the computer
3.Wait for awhile or select "Install or upgrade Fedora"
  
Actual results:
Waits for a bit, then a kernel panic

Expected results:
It proceeds on to Anaconda and I get to install Fedora

Additional info:
I have an Intel Desktop Board model DB67BG and a GeForce GT 430 video card (PCI ID 10de:0de1).

I can't really get all the panic information into here, but it looks like it's in the midding of initializing ACPI. It's in acpi_pci_root_init/acpi_bus_register_driver. At the very end it says that RIP is pointing somewhere inside pcie_aspm_init_link_state.
Comment 1 Bill Nottingham 2012-05-22 16:34:56 EDT
Can you attach a screenshot? (digicam/phone shot is fine, as long as the text is legible.)
Comment 2 Eric Hopper 2012-05-22 17:25:42 EDT
Created attachment 586194 [details]
A screen capture of the kernel panic

This might be a bit larger than you'd like. But the quality is definitely high enough to read. Ignore the white splotchiness, I have a really bad monitor.
Comment 3 Eric Hopper 2012-05-22 17:35:17 EDT
Also, RC3 doesn't have this problem. I just tried it.
Comment 4 Matthew Garrett 2012-05-22 22:10:20 EDT
Beta RC3 or final RC3?
Comment 5 Eric Hopper 2012-05-22 22:34:32 EDT
Well, that's a good question. I found it here:

http://dl.fedoraproject.org/pub/alt/stage/17.RC3/Fedora/x86_64/iso/Fedora-17-x86_64-DVD.iso

I suspect it's the final RC3.
Comment 6 Josh Boyer 2012-07-10 13:06:24 EDT
Did this wind up getting fixed in F17 final then?
Comment 7 Eric Hopper 2012-07-10 14:56:17 EDT
I didn't check. But I strongly suspect so. OTOH, I suspect it was also fixed 'by accident'. This is serious enough it would be nice to know a root cause. Though, of course, there are so many different kinds of motherboards out there that are broken in their own special ways that I don't really know how useful a root cause would actually be.
Comment 8 Josh Boyer 2012-07-10 15:00:06 EDT
While I agree knowing root cause would be nice, we just don't have time to dig into something that is fixed already.  Unfortunate, but true.

I'll close this bug out for now.  If this is seen again, we can reopen or report a new bug.
Comment 9 Eric Hopper 2012-07-10 15:04:45 EDT
I will try to remember to double check with the release version when I get back to the computer I had this issue with.

Note You need to log in before you can comment on or make changes to this bug.