Bug 824187 - lldpad: FCoE Application TLV fails to become active during install
lldpad: FCoE Application TLV fails to become active during install
Status: CLOSED DUPLICATE of bug 824188
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lldpad (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Šabata
Depends On:
  Show dependency treegraph
Reported: 2012-05-22 19:04 EDT by Eric Multanen
Modified: 2012-05-24 06:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-05-24 06:06:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Eric Multanen 2012-05-22 19:04:35 EDT
Description of problem:
The anaconda script for fcoe will start lldpad and then invoke a couple dcbtool commands to enable DCB and enable the FCoE application TLV for the selected interface.

The dcbtool commands may fail depending on timing of the commands and whether or not the link is up or down.  If the application TLV is not enabled, the results can be indeterminate.  Sometimes the installation may complete fine, in other cases, an important feature like priority flow control (PFC) may not be enabled by the switch and the resultant FCoE traffic needed for installation is not able to complete due to too many dropped packets.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  begin the installation process and take the options to install to
    special devices.  search for FCoE targets/LUNs.
2.  once the FCoE target search is completed, switch to a command line console 
    query the state of the FCoE application TLV.  Ex.  dcbtool gc eth0 app:fcoe

Actual results:
The dcbtool query will show that the FCoE Application TLV is not enabled.
(can also check for the 'dcbtool' commands in /tmp/program.log file and check
for the results of the commands to see if they succeeded or failed)

Expected results:
The FCoE Application TLV should be enabled.
Comment 2 Petr Šabata 2012-05-24 06:06:15 EDT

*** This bug has been marked as a duplicate of bug 824188 ***

Note You need to log in before you can comment on or make changes to this bug.