Bug 824277 - openwsman-python breaks at import in python - missing symbol SWIG_exception
openwsman-python breaks at import in python - missing symbol SWIG_exception
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openwsman (Show other bugs)
6.2
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Vitezslav Crhonek
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 03:05 EDT by Joakim Hovlandsvåg
Modified: 2017-12-06 06:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 06:56:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joakim Hovlandsvåg 2012-05-23 03:05:22 EDT
Description of problem:
openwsman-python will not be imported in python, it only breaks with an error.

Version-Release number of selected component (if applicable):
openwsman-python: 2.2.3-8.el6.x86_64
Python 2.6.6 (r266:84292, Sep 12 2011, 14:03:14) 

How reproducible:
Probably easy to reproduce, at least according to the error message.

Steps to Reproduce:
1. $ sudo yum install openwsman-python
2. $ python
3. >>> import pywsman
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.6/site-packages/pywsman.py", line 25, in <module>
    _pywsman = swig_import_helper()
  File "/usr/lib/python2.6/site-packages/pywsman.py", line 17, in swig_import_helper
    import _pywsman
ImportError: /usr/lib64/python2.6/site-packages/_pywsman.so: undefined symbol: SWIG_exception

Additional info:
$ lsb_release -a 
LSB Version:    :core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Distributor ID: RedHatEnterpriseWorkstation
Description:    Red Hat Enterprise Linux Workstation release 6.2 (Santiago)
Release:        6.2
Codename:       Santiago
Comment 2 RHEL Product and Program Management 2012-09-07 01:25:29 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Jan Pokorný 2016-08-10 14:55:49 EDT
See also:
http://oss.clusterlabs.org/pipermail/users/2016-August/003703.html
Comment 4 Jan Kurik 2017-12-06 06:56:17 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.