Bug 824307 - unassigned keysym causes crash
Summary: unassigned keysym causes crash
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-hunspell-table
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: anish
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-23 09:02 UTC by Daiki Ueno
Modified: 2015-04-12 23:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-09 22:55:15 UTC
Type: Bug


Attachments (Terms of Use)
patch (946 bytes, patch)
2012-05-23 09:02 UTC, Daiki Ueno
no flags Details | Diff

Description Daiki Ueno 2012-05-23 09:02:55 UTC
Created attachment 586281 [details]
patch

Description of problem:
When ibus-hunspell-table is enabled, typing key with unassigned keysym (NoSymbol) will cause crash.

Version-Release number of selected component (if applicable):
ibus-hunspell-table-0.0.6-1.fc17

How reproducible:
100%

Steps to Reproduce:
1. xmodmap -e "keycode 96 = NoSymbol"
2. enable "English - US(Hunspell)" engine in IBus menu
3. type F12
  
Actual results:
The engine process crashes with the following message:

 process 6891: Array or variant type requires that type string be written, but end_struct was written.
 The overall signature expected here was '(sa{sv}s(sa{sv}av))' and we are on byte 8 of that signature.
  D-Bus not built with -rdynamic so unable to print a backtrace

Expected results:
No crash.

Additional info:
I noticed this when using international keyboard with more keys than US keyboard.  Since IBus switches the system keyboard layout with "setxkbmap us", some keys (here "|") are unmapped.

It seems that ASCII range check in _table_mode_process_key_event() is fragile (patch attached).

Comment 1 Fedora Update System 2012-07-30 06:50:37 UTC
ibus-typing-booster-0.0.7-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.7-1.fc16

Comment 2 Fedora Update System 2012-07-30 06:51:07 UTC
ibus-typing-booster-0.0.7-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.7-1.fc17

Comment 3 Fedora Update System 2012-07-30 22:26:25 UTC
ibus-typing-booster-0.0.7-1.fc17 has been pushed to the Fedora 17 testing repository.

Comment 4 Fedora Update System 2012-08-09 22:55:15 UTC
ibus-typing-booster-0.0.7-1.fc16 has been pushed to the Fedora 16 stable repository.

Comment 5 Fedora Update System 2012-08-09 23:13:14 UTC
ibus-typing-booster-0.0.7-1.fc17 has been pushed to the Fedora 17 stable repository.


Note You need to log in before you can comment on or make changes to this bug.