Bug 82434 - redhat-config-printer-tui --Ximport --merge < filename.xml fails
redhat-config-printer-tui --Ximport --merge < filename.xml fails
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-21 22:16 EST by chris couples
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-22 10:49:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
exported printers file for my site (9.24 KB, text/plain)
2003-01-22 10:22 EST, chris couples
no flags Details

  None (edit)
Description chris couples 2003-01-21 22:16:23 EST
Description of problem:

When attempting to merge a newer version of the printer file dumped with:

/usr/sbin/redhat-config-printer-tui --Xexport > somefile.xml

using the command:

/usr/sbin/redhat-config-printer-tui --Ximport --merge < /home/setup/somefile.xml

I receive the following messages:

Traceback (most recent call last):
  File "/usr/sbin/redhat-config-printer-tui", line 8, in ?
    printconf_tui.startup_and_find_cmd()
  File "/usr/share/printconf/util/printconf_tui.py", line 2319, in
startup_and_find_cmd
    main.cmd_handlers[cmd]()
  File "/usr/share/printconf/util/printconf_tui.py", line 2003, in import_cmd_run
    ctx = AdmContext(xml = xmlstr)
RuntimeError: failed to create a context

...and the merge fails

In the above example, the exported file is copied onto an nfs share, so that a
number of identically configured machines will pick up any changes at the next
lpd restart.
Comment 1 Tim Waugh 2003-01-22 08:29:22 EST
Please attach the XML file you are using; I haven't been able to reproduce this
here yet, and it might be something specific to that file.
Comment 2 chris couples 2003-01-22 10:22:14 EST
Created attachment 89525 [details]
exported printers file for my site
Comment 3 Tim Waugh 2003-01-22 10:31:08 EST
That seems to have the whole thing twice.  If you just use the first copy, does
that work?
Comment 4 chris couples 2003-01-22 10:39:04 EST
Yeah, that worked. Sorry for the 'bug'.
Comment 5 Tim Waugh 2003-01-22 10:49:03 EST
No problem.
Comment 6 chris couples 2003-01-22 10:50:29 EST
I spoke too soon. I may need to open a new bug, but:

for the printer passilla, changing the type from jetdirect, with ip of
165.106.10.246 and port of 9100, to an lpd queue, with ip address of
165.106.10.246 and queue of '' (that's empty, as asked for by an Apple LW
16/600PS), applying (occasioning lpd restart), and then saving changes
(occasioning a second lpd restart), and then using the config-printer-tui tool
to export the "new" config

results in a file with passilla still being a jetdirect queue, with the initial
specs.

Might this prob. be that config-printer-tui expects some value for queue, and
because Apple's implementation is non-standard and doesn't take a queue name
when printing via TCP directly to the printer?
Comment 7 chris couples 2003-01-22 10:53:07 EST
uh, nevermind. major configuration screwup on my part. I am _really_ sorry for
the confusion.

Note You need to log in before you can comment on or make changes to this bug.