Bug 824356 - Nodejs not reachable or restartable
Nodejs not reachable or restartable
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Ram Ranganathan
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 06:30 EDT by Rob Millner
Modified: 2015-05-14 18:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:58:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Millner 2012-05-23 06:30:57 EDT
Description of problem:
The nodejs cartridge tests fail to reach nodejs and pushes hang.

Version-Release number of selected component (if applicable):
cartridge-nodejs-0.6-0.8.4

How reproducible:
Always

Steps to Reproduce:
1. cucumber li-test/tests/cartridge-lifecycle-nodejs.feature

  
Actual results:
Fails to become reachable.  And pushes timeout.


Expected results:
Tests run successfully.


Additional info:
npm appears to start and Apache gets a 503.  Git pushes get hung up on "npm install -d".
Comment 1 Ram Ranganathan 2012-05-23 16:03:02 EDT
Fixed with git commit 286291969d1003f49e79c5d68ae4a196e30f44f8 

selinux policies modifications removed the ability to use anonymous inodes. Added a policy back in.
Comment 2 Meng Bo 2012-05-28 05:55:48 EDT
verified on devenv_1806, issue fixed.
Comment 3 Meng Bo 2012-05-28 06:12:13 EDT
To verify this bug, because I cannot find the script, so I operated the following steps,
1, control the nodejs app with basic controls, like stop,start,restart,reload.
2, modify the deplist.txt in the repo and push it to server to trigger server side bundling, and npm install processing.

None of the operations cause the issue reproduced.
So mark this as verified.

Note You need to log in before you can comment on or make changes to this bug.