Bug 824380 - JPA errors in orm.xml file in Petclinic example when importing JBDS 5 Beta3
JPA errors in orm.xml file in Petclinic example when importing JBDS 5 Beta3
Status: CLOSED DUPLICATE of bug 801406
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Examples (Show other bugs)
2.0.0.ER5
Unspecified Unspecified
medium Severity medium
: ER1
: 2.1.0
Assigned To: Marius Bogoevici
Karel Piwko
petclinic
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 07:27 EDT by Tomas Repel
Modified: 2012-11-13 12:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 04:42:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Repel 2012-05-23 07:27:12 EDT
Description of problem:

Following error is shown in JBDS 5 Beta3:

Attribute "visits" in class "Pet" cannot be resolved
/petclinic/src/main/resources/META-INF/orm.xml
line 91
JPA Problem

The line from orm.xml file that causes the error:

<transient name="visits"/>

Version-Release number of selected component (if applicable):

WFK2 ER5
JBDS 5 Beta3

How reproducible:

Always.

Steps to Reproduce:
1. import petclinic example into JBDS
  
Actual results:

Five errors occur, one error is described above, another four similar errors 
occur too.

Expected results:

No error occurs.
Comment 1 Marius Bogoevici 2012-06-07 23:04:05 EDT
This looks like a spurious error to me. The deployment succeeds, which proves 
that the mapping is correct.
Comment 2 Karel Piwko 2012-09-24 10:29:43 EDT
This should be reverified with JBDS 5.0.1.GA.
Comment 3 Marek Novotny 2012-09-25 03:33:09 EDT
Marking as fixed in ER1 for verification with JBDS 5.0.1.GA
Comment 4 Tomas Repel 2012-10-01 11:26:35 EDT
These errors appear in JBDS 5.0.1.GA too.
Comment 6 Marek Novotny 2012-10-11 04:42:15 EDT
This issue is duplication of https://bugzilla.redhat.com/show_bug.cgi?id=801406

*** This bug has been marked as a duplicate of bug 801406 ***

Note You need to log in before you can comment on or make changes to this bug.