Bug 824391 - The instructions for using MySQL database in Petclinic example are obsolete
The instructions for using MySQL database in Petclinic example are obsolete
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Examples (Show other bugs)
2.0.0.ER5
Unspecified Unspecified
low Severity low
: ER2
: 2.1.0
Assigned To: Marius Bogoevici
Tomas Repel
petclinic
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 07:45 EDT by Tomas Repel
Modified: 2012-11-30 10:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 10:35:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Repel 2012-05-23 07:45:31 EDT
Description of problem:

The guideline how to switch database to MySQL is obsolete in Petclinic example.

Version-Release number of selected component (if applicable):

WFK2 ER5

How reproducible:

Always

Steps to Reproduce:
1. follow the guideline src/main/resources/db/mysql/petclinic_db_setup_mysql.txt
  
Actual results:

Uncommenting the MySQL JDBC Connector in pom.xml causes error:
Missing artifact com.mysql.jdbc:com.springsource.com.mysql.jdbc:jar:5.1.6

Expected results:

Petclinic is deployable and uses MySQL database.
Comment 3 Marius Bogoevici 2012-06-07 21:21:32 EDT
Fixed
Comment 5 Tomas Repel 2012-06-12 12:05:04 EDT
The MySQL JBDC Connector is OK now, but the content of file src/main/resources/db/mysql/petclinic_db_setup_mysql.txt is still obsolete. If the file is not going to be removed, it should be updated.

What I miss:
3) there is no longer the createDB.txt but there are two scripts for DB initialization now, initDB.txt and populate.DB.txt

4) there are more than one jdbc.properties currently, each one for different profile. The files can be found at src/main/environments/<environment>/resources/jbdc.properties

Other
 - the name of datasource has to be changed in persistence.xml and applicationContextDatasource.xml, because the default ExampleDS is not going to be used.
 - note that tests will fail after migration to MySQL
 - maybe link to the page describing how to configure the MySQL datasource for AS7
Comment 7 Marius Bogoevici 2012-10-11 04:18:08 EDT
Fixed
Comment 8 Marius Bogoevici 2012-10-11 04:18:17 EDT
Fixed.
Comment 9 Marius Bogoevici 2012-10-11 04:30:15 EDT
Removed the faulty instruction file.
Comment 10 Tomas Repel 2012-10-18 03:50:13 EDT
Verified in WFK 2.1.0.ER2.
Comment 11 Karel Piwko 2012-11-30 10:35:19 EST
Distributed as a part of WFK 2.1.0.GA release.

Note You need to log in before you can comment on or make changes to this bug.